1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Western HTS Plow

Discussion in 'Commercial Snow Removal' started by crackstp, Nov 13, 2011.

  1. crackstp

    crackstp Junior Member
    from MN
    Messages: 2

    Have a new (1 yrs old), went to put it on the truck and it will not move. with every thing hooked up I hit the up button and all it does is try and go to the right, it can't because it is already all the way right, it does the same thing with the left button. I thought it might have corroded hole on the 11 PIN connector. I did try a new truck side harness no change. Also I can not take it to get repaired because It will not come off the ground.
     
  2. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    The 11 pin has no control functions in it, it's only for lighting. All control functions are on the two small pins in the battery cable harness.

    How mechanically included are you? The HTS is multiplex controlled so some of the normal tricks of the trade can't be used to diagnose it- but some can. Checking the fuses under the pump cover, testing the S2 valve to see if it has magnetism when it actually shouldn't, and making sure the control pins in the battery harness cables are in good shape are the first few things needing done.

    You can always raise it with a floor jack and run a couple ratchet straps around it to get it in for repairs. Just because it's direct lift doesn't mean you cannot "short chain" it.