1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Western electrical problem 4 port ISO

Discussion in 'Western Plows Discussion' started by jasonz, Aug 4, 2014.

  1. jasonz

    jasonz Senior Member
    Messages: 250

    Plow worked fine last season put it away and ended up
    Buying a wideout for that particular truck. Go to show the old Ultramount pro plow to a buyer and it just clicks and the controller (hand held) shuts off on every command except down. Hook the plow up to another truck and plow functions fine.

    Swapped controllers same issue
    Swapped out motor relay same issue
    Checked cable for frays or cuts and didn't see anything
    Greased the plugs same issue
    Ran a jumper cable from the neg post on plow to neg battery post on truck same issue

    All the connectors on the truck side look good and clean.
    Control harness through the cab looks fine no cuts.

    Where do I go next?
     
  2. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,940

    Spread the pins out for the controller. The connector inside the trk 6 pins.
     
  3. jasonz

    jasonz Senior Member
    Messages: 250

    Edit just hooked the truck to another plow and it worked??
    So just this combo of truck and plow.

    Just hooked problem plow up to a third truck and it worked fine.
     
    Last edited: Aug 4, 2014
  4. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,940

    Ck the controller connection. Inside the trk. And then the underdash power wire you have tapped into a fused ign source.
     
  5. Whiffyspark

    Whiffyspark 2000 Club Member
    from SOMD
    Messages: 2,402

    Id say bad grill connexion
     
  6. jasonz

    jasonz Senior Member
    Messages: 250

    Why would it only be with this combination?

    Plow works fine on my other trucks

    Truck works fine on my other plows
     
  7. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,940

    Wiring does funny things
     
  8. 1olddogtwo

    1olddogtwo PlowSite Fanatic
    Messages: 11,503

    Confused..... WO is fleet-flex Two plug..,older straight are 3 plug, newer are 2 plug....is that the set up have on straight blade, two plug?
     
  9. 1olddogtwo

    1olddogtwo PlowSite Fanatic
    Messages: 11,503

    Oh wait, you don't have WO wiring installed yet?
     
  10. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,940

    Nope. He don't
     
  11. 1olddogtwo

    1olddogtwo PlowSite Fanatic
    Messages: 11,503

    I see.

    The problem is clear, the plow wants to stay with the truck. Often, the truck and plow will develop affection for each other. Its like woman and money, they go together. after divorce (selling them as package) you will be quite happier.