1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Western Electrical HELP!!!!

Discussion in 'Western Plows Discussion' started by VistaProperties, May 30, 2011.

  1. VistaProperties

    VistaProperties Junior Member
    Messages: 2

    I just installed a used 2003 western poly plow on my wifes 2005 F-350 and I downloaded the installation manual from westerns site. After i connected all the wires just as the manual said I have no power at the controller. I DO have power to the fuses on the controller and the Accessory wire is connected to switched power. My remote wont show the power light and if i push the buttons nothing happens at all (the plow is not connected to the truck at this time) Any ideas of what to try??? :confused:
  2. 06Sierra

    06Sierra PlowSite.com Addict
    from Maine
    Messages: 1,328

    The plow has to be on the truck for the control to work.
  3. Tony350

    Tony350 Senior Member
    Messages: 546

    I thought I had the same problem when I installed the plow myself to. Like 06 sierra said plow has to be hooked up.
  4. VistaProperties

    VistaProperties Junior Member
    Messages: 2

    Problem Solved

    Yup, the plow had to be hooked up.....Feeling a bit stupid at the moment! Should have tried that from the start.
    Thanks alot:mechanic: