1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Western Classic Pump problem... broken quick connect

Discussion in 'Western Plows Discussion' started by soundnstyl, Jan 12, 2011.

  1. soundnstyl

    soundnstyl Member
    Messages: 46

    Sooo... I broke the quick connect off the pump (see pictures) it controls the left and right movement of my plow. anyway of repairing/replacing just that piece? or do i have to replace the entire thing? what do i need to be searching for? Thanks all! hope y'all having a good time this year! and old man winter is giving you what WE ALL ask for.



  2. soundnstyl

    soundnstyl Member
    Messages: 46

    also. anyone have a manual?
  3. wild bill

    wild bill PlowSite.com Addict
    Messages: 1,239


    you should be able to use a short base ez out extractor and carefully remove it .watch shavings inside the port .look in snapon catalog this is a sample

    Extractor, Multi-Spline, 5/16"
    Stock #: REX110A

    Shoulder on extractor prevents extractor from e... Learn More
    Add to Cart
  4. soundnstyl

    soundnstyl Member
    Messages: 46

    problem... we tried an extractor... and ummmmm... the extractor broke... i think i know what i need... but can i buy what is in yellow?

  5. soundnstyl

    soundnstyl Member
    Messages: 46

    bump... any input would help. thanks
  6. twinman326

    twinman326 PlowSite.com Addict
    Messages: 1,683

    It is call the "4 way controller valve".Part #49020. It cost about $390.99

    Did you try drilling a hole in the middle of the broken extractor, using a smaller extractor, plus a little heat to remove it??

    Probably what happen, you try to extract the broken part, and didn't use a little heat. The broken probably was rusted and wouldn't move, and you use more force then you should of, and snap.........
  7. brrybck

    brrybck Junior Member
    Messages: 8

    ive got pump housing with 4 way valve on it 100 plus shiping
  8. soundnstyl

    soundnstyl Member
    Messages: 46

    thanks for the help guys... soo over the weekend, we tried a couple things... one was to drill out the extractor and put in a smaller on... but the extractor was hard, it ate through my drill bits... we did find a solution, there is a screw on the front of the block... we use that to connect the hose (see pictures). it seems to be working. not sure what it means in the long run though! maybe a quick fix and if anyone has an issue like this in the future.


  9. twinman326

    twinman326 PlowSite.com Addict
    Messages: 1,683

    Looking at the manual, instead of being in the center between the "curb side", and the driver side cushion valve, you hook in front of the "curb side" cushion valve.. I really don't know it you will encounter any problems in the near future..Actually you luck out if the tap broken before it enter the channel........If it was all the way through, then it broke, I believe there would be a blockage.

    retap line.jpg

    retap line.jpg
    Last edited: Jan 17, 2011