1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Western causing overheating?

Discussion in 'Western Plows Discussion' started by LLMSERVICE, Nov 19, 2005.


    LLMSERVICE Junior Member
    Messages: 8

    I've just had a Western Pro 8 ft ultramount installed on my 04 Sierra 2500 and this morning, during the first plowing run with it it started to overheat. The outside air temp was about 1 degree C (34 F). I pulled over, turned it off and waited a couple of minutes, restarted and the temp guage went back to normal. It came close a couple of more times today. I've plowed with a number of Westerns on GMC 1500 and 2500 and never had this occur before

    Anyone have similar problems or can suggest some ideas or driving habits I can try to prevent this?
  2. Synergyracing

    Synergyracing Member
    from Indiana
    Messages: 54

    let us know more about your truck... gas/diesel??? mods?

    LLMSERVICE Junior Member
    Messages: 8

    Its got the 6 litre gas, auto tranny, engine and tranny coolers, and transmission temp guage (factory installed). Other than that, no modifications. Its been installed by a reputable Western dealer that I've dealt with many times before.

    The engine temp guage will sit at normal range consistently, than spike up near 125 degrees, while I was driving between jobs...at about 35-40 miles per hour and generally not more than 15 minutes driving time between jobs when it occured. Shutting down the engine for as little as a couple of minutes solved the problem and it would drop down to normal operating temp. Oddly, there was no tell tale steam coming from the hood, and it was only the guage and the warning chime that kicked in. At least whenever it spiked, I was near a donut shop...good excuse for a break.

    One thing I tried was transporting the plow in a lower position, with the idea that perhaps the larger blade surface of the pro was blocking air from entering the rad. That seemed to keep the heating issue at bay the rest of the day.

    When actually plowing parking lots overnight and driveways today (about 15 hours total running time), it was performing fine.

    MIAWPUKEK Senior Member
    Messages: 267

    onboard thermometer rises

    I got a western 7'6" pro plow, when I had it on my '03 F150, I found that when I travelled on the highway, if the blade was straight, my onboard thermometer would go up, almost to 20 degree celsius sometimes, but when I angled it, it would drop back down to the 'real' temperature. If it's causing my thermometer to go up, I say my engine was getting hot as well.

    LLMSERVICE Junior Member
    Messages: 8

    My on board thermometer was spiking as well. I'm trying to keep from travelling on the highways too much between jobs.

    Would angling the blade somehow get more air over the rad?

    I just spoke with my Brother in law in Ottawa who, it turns out, works for a Western dealer and he suggested that I might need an auxilary fan installed.
  6. nekos

    nekos Senior Member
    Messages: 586

    i had the same problem driveing in the summer with my plow on < don't ask >
    try to keep the blade a low as possable. on my truck , if the top of the blade is even with the bottem of the plow light's / driveing lights i get enough air to keep the engin cool.
  7. Runner

    Runner Senior Member
    Messages: 957

    For longer runs, I have to run mine just off the ground. In order to do this, I have to set it straight so I don't scrape the edge. I was always going to build a foil setup to put on my mount to direct air down to the radiator, but never have.
  8. Frozen001

    Frozen001 Senior Member
    from Rome NY
    Messages: 908

  9. dmaxallitech

    dmaxallitech Junior Member
    Messages: 2

    There is a TSB on the 6.0 engines that replace the fan clutch for an overheating condition with a plow. I've done a couple here at the shop and it seems to work