1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

wester snow plow dim lights but no brights

Discussion in 'Western Plows Discussion' started by mattpiotrowski, Jan 7, 2010.

  1. mattpiotrowski

    mattpiotrowski Junior Member
    Messages: 26

    I got a Western UniMount snow plow I have dim lights but when i go to brights the lights go out? Could it be a bad relay?

    Thanks
     
  2. twinman326

    twinman326 PlowSite.com Addict
    Messages: 1,683

    could be a bad ground. Check the black/orange wire off the relay and onto the negative side of the battery. Look for corrosion in the grill connector, relays, neg battery terminal, and solenoid small terminal.
     
  3. wideout

    wideout Senior Member
    from iowa
    Messages: 727

    What kinda truck is it on? new plow or have you used it in the past
     
  4. mattpiotrowski

    mattpiotrowski Junior Member
    Messages: 26

    its on a 2003 chevy 2500Hd but the plow is a western UniMount Chevy/GMC 1500 1999 and later model No. 3515
     
  5. Crash935

    Crash935 2000 Club Member
    Messages: 2,377

    Iso or relay harness? Brights out only on the plow? Was this just swap to the 03 from the 99? Did you just reuse the harness from the 99?
     
  6. mattpiotrowski

    mattpiotrowski Junior Member
    Messages: 26


    no the plow was on the truck when i bought it. i bought it USED back in 2006.
     
  7. Crash935

    Crash935 2000 Club Member
    Messages: 2,377

    what harness?