1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Weirdness with two different XV Blades

Discussion in 'Fisher Engineering Discussion' started by ducaticorse, Nov 22, 2014.

  1. ducaticorse

    ducaticorse PlowSite.com Addict
    from we
    Messages: 1,426

    I converted two trucks to XV blades this season. I moved one the other day and all went fine. Today I went to move the other one and had some issues.

    The following is kinda what happened.

    Is there a reason other than the solenoid connections being switched up that one XV plow will run proper, and another on the same controller same truck will not?

    Some of the solenoids are firing and the pump is running but the controls are all messed up. I haven't gotten into it yet but I'm hoping it's easy like my guys greased and serviced it and just hooked the wires up wrong.

    Thoughs?
     
  2. gtmustang00

    gtmustang00 Senior Member
    from Berlin
    Messages: 747

    We need more info on what it's doing and not doing.
     
  3. Yates004

    Yates004 Member
    Messages: 35

    x2 on this...
     
  4. NHresident

    NHresident Senior Member
    Messages: 285

    for starters Id say its a plow side problem not trk with the plow that doesn't work right
     
  5. kimber750

    kimber750 PlowSite Veteran
    Messages: 3,663

    I would say one plow is broke. :mechanic:
     
  6. Mark Oomkes

    Mark Oomkes PlowSite Fanatic
    Messages: 10,868

    Lmao

    Winner,winner, chicken dinner.