1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

weird light question

Discussion in 'Truck & Equipment Repair' started by badbowtie, Nov 20, 2013.

  1. badbowtie

    badbowtie Senior Member
    Messages: 106

    I have a 99 K3500 old body style that I bought a older meyer plow that I put on month ago. That uses the up and down switch and left to right switch and the pull knob for the lights. I have remote start on the truck also for a couple years. I noticed if I start truck with key the pull knob switch does not light up unless I turn the brights on and my pillar gauge does not light up. If I remote start the truck gauge pod and pull knob will light up like supposed to and then wants remote start times out and turns off so do the lights. This is with the light bar / pump hooked up to the truck or with it not even hooked does not matter.
     
  2. badbowtie

    badbowtie Senior Member
    Messages: 106

    I am going to try to pull truck in garage this weekend and check around on the wiring and try to determine what is going on. Any ideas what is going on?
     
    Last edited: Nov 22, 2013
  3. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,973

    your remote start light hot wire is before the switch, meaning your remote start sends pwr to your lights not your tk headlight switch. I would ck pwr output of the headlight switch
     
  4. badbowtie

    badbowtie Senior Member
    Messages: 106

    But what has really confused me is when I turn the headlight switch to turn headlights and marker lights on everything works inside and outside other than the plow pull switch and the trans temp gauge light on the pillar.
     
    Last edited: Nov 22, 2013
  5. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,973

    So where is the pillar light hooked up to the switch side? Before the remote start or after
     
  6. badbowtie

    badbowtie Senior Member
    Messages: 106

    If I remember right both are solder at the same spot on the marker light wire behind the headlight switch. But before I hooked the plow up the trans temp gauge light has worked for two years with just flipping light switch on or using remote start until I installed plow.
     
  7. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,973

    ok,,,,then im thinking its the plow wiring that's having the issues. maybe the pwr or the gnds