1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Weird issue in reverse.

Discussion in 'Ford Trucks' started by CornerStoneProp, Dec 6, 2011.

  1. CornerStoneProp

    CornerStoneProp Senior Member
    Messages: 222

    I have a 2009 F250 with a 5.4 auto. I was plowing that last storm in Oct, and while going into reverse only, the throttle was useless. It did not feel like slipping, the engine would not rev at all. I would come to a complete stop again and it would work fine after that. I have no issues backing up my boat or any other heavy trailer, but backing after 8 hours of plowing it acted up. This has not happened since either so I am just looking to find out what to look out for. I have a warranty still so the dealer will have to fix the issue.

    Thanks in advance,
    Chuck
     
  2. swtiih

    swtiih PlowSite.com Addict
    Messages: 1,179

    never had this problem but interested in the outcome
     
  3. Silverstreak

    Silverstreak Senior Member
    Messages: 168

    i guess ford switched over to fly by wire

    (no more throttle cable in the 5.4)

    same as my 00 diesel, the floor pedal is an electronic reostat that gives the motor more juice when you push

    check the pedal connector, then check under the steering column for a stripped or frayed OD light wire, i replaced the pedal on mine before i found out that the wire for the OD was rubbing on the aluminum under the column cover giving me a dead pedal sometimes
     
  4. CornerStoneProp

    CornerStoneProp Senior Member
    Messages: 222

    I will look into that thanks!
     
  5. kurtandshan

    kurtandshan Senior Member
    Messages: 323

    Had this exact issue come up today on my 07 5.4. Any update?