1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

VX95- Broke Again!

Discussion in 'SnowDogg Snow Plows' started by stanger86, Dec 8, 2011.

  1. stanger86

    stanger86 Member
    Messages: 40

    Ok, so Im starting to get fed up with this VX95. I bought it two winters ago. The first winter seemed to work fine, until the hydraulics started going haywire. Talked to Smoorman and got the main block replaced with new solenoids. Seemed to fix the problem. The next winter, started out with the same problem. only this time we had to get a new controller. Again seemed to fix the problem for a while. In the meantime, we had to replace the plastic snow deflector because they both broke, buyers sent us out some nice new rubber ones. Then the jack ended up breaking (the handle and cranking mechanism..so we got that replaced again under warranty. After that we decided to try and use this plow a lot less in fear of something else breaking on it, so we winterized it and put it away. Well we pulled it out last week to get ready for plowing as we were in the middle of getting new trucks and needed another plow to use. We hook it up and bam, it didnt have half of its functions. plow wings wouldn't go out or in, blade wouldn't drop..ect ect..we replaced all fluid and nothing. Looked over all the wiring on the truck and all grounds were perfect, no relays out, nothing wrong there. So we call our local dealer, and he thinks its the controller. So we take it to him and he says we have to give him 300.00 for a new controller and then we will get reimbursed from buyers for warranty...umm ok? not that big of a deal i guess, but a little weird considering we have never had to give a deposit for warranty work..but whatever. so we get the new controller, and same damn thing, nothing is working, in fact we have less function with the new controller than the old one, go figure! We can hear the pump moving, but no action. So now the dealer thinks its the main block on the plow again. says its 800.00 dollars deposit, then once he gets the core we will get reimbursed. Again, a little messed up we have to pay for these deposits on a warranty item, but screw it, if its going to fix my plow, then whatever it takes. So we get the new block on there and, again. Not ******* fixed! So here I am again, with a unusable plow, with basically all new parts. What is wrong with this thing? It surely cant be the remote, or the main block, or the motor...as those all have been replaced! Smoorman Help me out here!
  2. Jim@esitrucks

    Jim@esitrucks Inactive
    Messages: 1,124

    May I suggest you go to snow doggs web site...click the parts search button, you will see at the top a live chat button....thats the easiest way to get ahold of him. Good luck
  3. djagusch

    djagusch 2000 Club Member
    from mn
    Messages: 2,068

    Have the dealer quit guessing and call Scott. They answer their phone's pretty quickly.

    As for your problem. Mr Dealer needs to look at his TSB's about the lift ram. What happened is the lift ram packing is breaking up and gunking up valves, etc. The ram has a date code on it stated in the TSB, and since he has not replaced it is the older one. Replace the lift ram, remove all the valve to clean the screens, flush hoses, etc. Your problems should be fixed then.

    I'm glad I have a decent dealer. For the warranty deposit's that is the dealers deal. Guessing he doesn't have the cash to float for parts. Is he a sub dealer?
    Last edited: Dec 8, 2011
  4. stanger86

    stanger86 Member
    Messages: 40

    Thanks guys! I will contact him about the lift ram. Im not sure what kind of dealer he is, he runs it out of his dinky little shop bay. He seems like a lawn mower mechanic just getting into plows..so maybe hes just too new to it? Not sure, but thanks for the help!
  5. leigh

    leigh PlowSite.com Addict
    from CT
    Messages: 1,968

    How did you make out?Resolved?
  6. stanger86

    stanger86 Member
    Messages: 40

    we had to replace all the wiring on the truck. A new hydraulic lift cylinder. Then an entire pump motor, and hydraulic block with all the valves. basically a new plow...
  7. G&T LAWN

    G&T LAWN Senior Member
    Messages: 149

    If you have any more problems call Hatcher Mobile Services. He is a sub dealer for snowdogg and a sharp guy. I have bought 2 plows and they are working great. He is right in Omaha. 402-850-3569
  8. smoorman

    smoorman Sponsor
    Messages: 447

    Unfortunately it sounds like the truck side harness may have been the issue all along (after the hydraulics were upgraded). A bad truck side harness is very unusual - but I should have been more thorough in the troubleshooting before I sent the other parts.

    I'm glad it worked out and am sorry for the additional time it took.