1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

VMD Electrical Problem?

Discussion in 'SnowDogg Snow Plows' started by nick_snonomo, Dec 19, 2014.

  1. nick_snonomo

    nick_snonomo Junior Member
    Messages: 18

    Hey guys, I'm a homeowner and only plow my own site out in the country. Got my Snowdogg VMD all ready to go yesterday, however there seems to be a disconnect in the power somewhere.

    I hooked everything up, and I can't get my controller to turn on.

    I took a continuity meter and tested the power at the solenoid/relay under the hood, and there's power there, but then I checked at the truck-side plug with the two big pins and didn't have any power there.

    Any idea's on how to diagnose what's going on?

    I'm not that handy when it comes to these kinds of things, so any help would be appreciated.

    Thanks guys
     
  2. Mr.Markus

    Mr.Markus PlowSite Fanatic
    Messages: 5,178

    Look for a power lead that goes from the controller to your fuse box, it probably wiggled loose...
     
  3. djagusch

    djagusch 2000 Club Member
    from mn
    Messages: 2,072

    If the controller doesn't light up its your key on pwr. Has a in line fuse that could blow or its not connected at the source