1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

vmaxx 8ft salters

Discussion in 'SnowEx Products' started by adamhumberview, Jan 20, 2012.

  1. adamhumberview

    adamhumberview Senior Member
    Messages: 276

    hey guys.. i have a few snow ex 8ft's.. and for some reason.. i cannot get nice flow out of the auger.. i run it on 99 auger speed and 50 spinner speed.. the only way the salt flows nicely is if the keep the vibrator on all the time.

    any help?
  2. Turf Guy

    Turf Guy Member
    Messages: 51

    From my experience, at least the salt we get down our way, has a lot of fines in it. The fines attract moisture, and it makes it bridge in the spreader. Snow Ex units seem to like dry, free flowing material. We run our vibrators all the time, and problem solved. The nights that we don't have to, are nights below -10 deg, when the moisture is froze out of the salt. Then it flows great. I think it's just the nature of the beast!!!

  3. musclecarboy

    musclecarboy 2000 Club Member
    Messages: 2,303

    Is there a drawback to running the vibrator all the time or just noisy/pain in the azz?
  4. Turf Guy

    Turf Guy Member
    Messages: 51

    Personally I haven't had any problems, and the one site we do as 7 acres of blacktop... Maybe others can chime in if they have had problems.... The only draw back I can see is it takes more power to run the unit, so hence more load on your alternator....
  5. goel

    goel PlowSite.com Addict
    Messages: 1,079

    never had a problem running them all the time. We have 4 snow ex's and the vibrators are always on when spreading.

    Also helps, very distinctive sound difference when you are low on salt and then out.
  6. snowguys

    snowguys Senior Member
    Messages: 708

    i just bought a snow ex 8000 and the flow sucks i have a 6000 and the flow is fine . do any of you guys have a 8000? did you put a 2nd vib on it? if so where?
  7. adamhumberview

    adamhumberview Senior Member
    Messages: 276

    we just recently cut a small portion of the rear part of the auger shield.. helped 10x
  8. Wayne Volz

    Wayne Volz Senior Member
    Messages: 694


    We rune several units and run the vibrators all the time. No battery of alternator issues and material flows great.