1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Very dissappointed with my new 06 F250

Discussion in 'Ford Trucks' started by Focker, Feb 7, 2007.

  1. Focker

    Focker Member
    Messages: 31

    I am just creating this post so I can vent a little bit and so everyone can add their $.02 in on the subject! I have had nothing but problems with this POS and I am just sick of it! I have been a Ford owner since I started driving and I cannot begin to explain how disappointed I am the quality of my truck! So far, this is what has gone wrong with it: The paint was coming off of the emblems, had to be replaced--missing blocker beam from dealer trade(truck already had a plow installed and removed)--missing lower valance(same reason)--clunking, squeeling from front end--automatic locking hubs are bad, dont disengage properly--transmission squeel in between shifts a couple times--Tach went wacky and was reading 1K rpm too high--nasty whining sound at start-up in the mornings---Thats about all I can think of right now!! I am extremely disappointed in the gas mileage of my 5.4, since I have owned it the absolute best I have achieved is 11.5mpg!!! I don't drive it hard and most of my travel is highway! My last tank that i just filled up consisted of at least 75% highway driving and I got 10mpg!!!...Its F'in gettin worse....I am irritated as hell! No, I did not buy this thing for its great gas mileage, but I just think this is unexeceptable! I have a buddy with a 8.0L 2500HD and he averages 13mpg for Chrissake!!!

    The truck was BRAND NEW when I purchased it, it had 450 miles on it from the dealer trade...This was obviously not clear so I decided to add this!
    Last edited: Feb 7, 2007

    CARDOCTOR PlowSite.com Addict
    Messages: 1,304

    you bought a used truck that was used for plowing. what do you expect. probaly was abused and then traded. hope you bought an extended warranty

  3. Focker

    Focker Member
    Messages: 31

    No sir, I bought a brand new truck that the dealer in Indiana had a plow installed on. They removed it for the dealer trade because I already had a plow! Sorry I should have been more clear on that! The truck had 450 miles on it from the drive up when I took delivery of it!
  4. DeereFarmer

    DeereFarmer PlowSite Veteran
    Messages: 3,296

    I agree. Most used plow trucks that are traded in being that new are not good news. My mileage has gone down the crapper in all vehicles for some reason as well. I know it is cold, but my mom's Durango went from 14.5 MPG to 12.6 MPG withing a tank full and has stayed that way. It gets the same use day in and day out.
  5. Focker

    Focker Member
    Messages: 31

    I edited my original post so it was clear that the truck was new!

    CARDOCTOR PlowSite.com Addict
    Messages: 1,304

    i know some parts of the country use oxygenated fuel during the winter to help with emissions . my mileage is always worst in the winter .sorry about braking your chops about the used truck didnt know it was new.im sure the dealer will make good on any problems or contact a local plow installer they probaly have a few beam blockers laying a round

  7. spittincobra01

    spittincobra01 Senior Member
    Messages: 193

    a friend of mine had a similar ordeal with a "brand new" 05 that the dealership had used to plow thier lot. it only had a couple hundred miles on it, but it had creaks and rattles, squeaks and so on... maybe this could be the case with yours and they didn't tell you? If so, that would warrant them having to replace it
  8. Sharpshooter77

    Sharpshooter77 Senior Member
    Messages: 162

    I also have to add a few things to this thread. The company that I work for (Gold Star Trucking) bought a brand new 2006 F-250, with the 5.4 liter, and an 8 foot fisher MM2. Me and my boss are the only 2 people that drive this truck. First the speedo was going crazy. When you go 30 m.p.h it says that you going 95 or 100. Then the tach would read 5,000 at idel then 200, then it stoped working. The front end had a klunking sound. And the motor hesistates and couldn't get out of its own way. I like the truck when Its running right. I would like to take my 351 windsor and C6 tranny drive-train and drop that into the new 06 style. I perffer the 03's and 04's that we have. My truck that I really like to drive is the 2005 F-550. Man that 550 is a sweet rig.
  9. Zack1978

    Zack1978 Member
    from NJ
    Messages: 82

    WOW, and I am looking at getting a new F 250? Might I be crazy to think about this?

  10. stroker79

    stroker79 2000 Club Member
    Messages: 2,802

    my 03 250 is great! its a diesel and I have had no issues with it at all.

    I am sorry for your problems but for the kind of issues you are having I would wonder how the previous dealer treated the vehicle. They could have beat the piss out of it on the drive up, or used it plow thier own lot. Hopefully you get it all straightend out, you cant expect every single truck thats produced to be PERFECT. unfotunately, you may have gotten an inperfect one. Again, I do hope this all gets solved.
  11. 90plow

    90plow Senior Member
    Messages: 734

    My 5.4 is a little cranky on cold mornings too. It whines for about 6 seconds then stops but other than that the truck runs like a champ, it also squeals between shifts when I floor it, I think its either the line pressure from the tranny or the belts squealing from the sudden change in RPMs.
  12. dodgeguy99

    dodgeguy99 Senior Member
    from mn
    Messages: 272

    i drive a 02 550 V10 at work and i have also noticed the squeals inbetween shifts it has done that since new not sure what it is
  13. Focker

    Focker Member
    Messages: 31

    Thanks for all the well wishes! I have always loved Ford's and I hate to be disappointed in them. I will be riding the dealer's ass about everything and it does make me wonder what the truck was put through before I got it! I just hope this POS gets better cuz I was already looking at other trucks!
  14. vis

    vis Senior Member
    from 4
    Messages: 324

    Same spedometer problem on our 06 f 550......been to dealer 2x cant find nothing wrong...of course it works fine when i bring it there.

    Some times it reads 0 all the time, some times it is 40 mph too high, or will not drop below 30....very weird......hope its not leading to anything else because overall im very happy with it....
  15. dodgeguy99

    dodgeguy99 Senior Member
    from mn
    Messages: 272

    looking at them dodges i hope ;)
  16. SpruceLandscape

    SpruceLandscape Senior Member
    Messages: 248

    Just make sure that you document the heck out of everything and keep all the print-outs from the dealer each time they attempt to fix something. That way, if worst comes to worst and you end up battling Ford to buy the truck back from you, you have everything in your hand instead of relying on the dealer to provide your service records.
  17. Jay brown

    Jay brown PlowSite.com Addict
    Messages: 1,783

    that's too bad. i've had nothing but excellent luck with my fords. finally had the FIRST problem ever with my 97 (vacume pump). never had ANY problems with our 2001. i think i would trade it off while it's still new. you might loose $5-10k but it will be worth it in the long run. try one of thoes new toyotas , i've never owned one but everyone knows if you are looking for a GOOD reliable truck, that's what you need. if you want power and capacity and lots of repairs buy a new ford. ha ha
  18. Sweetpete

    Sweetpete Senior Member
    Messages: 325

    Ditto....my 04 does the same thing. Besides that, this truck has been awesome. I love it. I'll definately look at the Ford's for my next truck. But we'll see what Dodge and GM offers too.

    I love competition.
  19. Buster F

    Buster F Senior Member
    Messages: 208

    There was a recall on my 06 f 150 that required a "gauge cluster recalibration". I'm not sure if this recall applied to all the f series trucks but it might be worth looking into
  20. Snow-Kid

    Snow-Kid Senior Member
    from nw ohio
    Messages: 364

    I had the same problem with my speedo not reading correctly. Went to the dealer 3 times then the forth time the dealer ordered a new instrument cluster and so far it has worked. As far as the paint coming off the side emblems my buddy had his come off his 05 with in the first month he had the truck. He has had the dealer change them twice. Hope you get every thing worked out.