1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

valve body

Discussion in 'Fisher Engineering Discussion' started by t-dawg1982, Nov 25, 2009.

  1. t-dawg1982

    t-dawg1982 Member
    from canada
    Messages: 52

    on the old speedcast valve bodies,the part that the cabel hooks to,to move the plow,should they be spring loaded,I can pull out the raise and angel ones with my hand but I have to push them back in,it this normal?
     
  2. BoulderBronco

    BoulderBronco Senior Member
    Messages: 233

    Yup. Normal. There is no spring in the cable system. The cable is suposed to be attached to a bracket just before the valve. This keeps the cable and pistons operating smoothly and allows for adjustments on the cable. Scroll down a bit on this page and you can see what I'm talking about.
     
  3. t-dawg1982

    t-dawg1982 Member
    from canada
    Messages: 52

    cable

    I mean the 2 valves that the cabels hook to,when I pull them out by hand the stay like that,then i have to push it back in,I am also wondering should they be pushed in all the way then hook the cables on to try and get the cables adjusted,the thing is I am just installing it and I don't have any fluid going threw it yet could that be the reason they are staying open,one more thing,to adjust the cables,should it be done with the 2 nuts that hold the cables to the valve bracket,or using the little nuts on the end of cables where the hook goes to attach to valve,what si the easiest way?
     
  4. Nigel Tufnel

    Nigel Tufnel Junior Member
    Messages: 5

    I was curious about this as well. Facing the unit, the valve on the right, returns freely when I push it, however, the valve on the left required a couple of taps with the hammer and a little "deep creap" to get it to free up. It only returns when I pull it with pliers. I would think once the unit is under pressure, it would move more freely.
     
  5. t-dawg1982

    t-dawg1982 Member
    from canada
    Messages: 52

    I just made up a bracket for the pump off of my alt,when I measure for the belt I get 56inch,can u get the belts in all diff lenths,also are they hard to get?