1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

V-10 Popping Thru Intake

Discussion in 'Ram Trucks' started by yzf1000_rider, Oct 13, 2006.

  1. yzf1000_rider

    yzf1000_rider Senior Member
    Messages: 147

    OK a Friend of mine brought his 2000 2500 over to the house yesterday and said i think i blew my engine i went outside to look at it and it is popping thru the intake. now i know it could be a bad valve worn rocker or bent push rod what iam wondering is if anyone else has had this problem before and point me in the right direction. it has 88,000 on it but it has 14 inches of lift and 40 inch ground hawg tires and he hasn't been very easy on this truck in the mud. any help would be greatly appreciated. thanx.
     
  2. SnoFarmer

    SnoFarmer PlowSite Fanatic
    from N,E. MN
    Messages: 8,490

    Sounds like it jumped time, from him throttling her through the mud..
    I bet his tac needle is in the red a lot?

    JMO:waving:
     
  3. itsgottobegreen

    itsgottobegreen PlowSite.com Addict
    Messages: 1,351

    Sounds like time to drop a 12v in it. :rolleyes:
     
  4. Brian Young

    Brian Young PlowSite Veteran
    Messages: 3,382

    Like a few other's have said, sounds like timming may have jumped.
     
  5. yzf1000_rider

    yzf1000_rider Senior Member
    Messages: 147

    well got out the 6 ft step ladder today and went to work on this thing. turns out the number 2 cylinder exhaust rocker backed off and turned sideways. called my buddy up told him what happened and he said yea its happened before and the last guy that worked on it lost a push rod. so i told him lets tear the intake off and look for it found it laying in the back of the motor by where the dist. would be if it had one. so now he has a spare push rod. got out the loc tite and put it back together runs great again till he destroys it again. THANK -YOU everyone that sent me some suggestions. hopefully he wont have this problem again if he can just stay out of the throttle.