1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

upfitter switches

Discussion in 'Ford Trucks' started by tilawn, Dec 21, 2008.

  1. tilawn

    tilawn Member
    Messages: 55

    I have a question about the upfitter switches in my 2007 F-550. I am trying to hook up a Peterson mini-lightbar (quad flash strobes) light is mounted wires ran not working I wired it this way black wire to ground at the battery and red wire to the orange wire with light blue tracer on it. I flip Aux 4 on dash and NOTHING I have checked fuses and relays but am scratching my head on why they dont work. Any help would be greatly appreciated and THANK YOU in advance
     
  2. stangman35

    stangman35 Senior Member
    Messages: 267

    Did you have the key turned on?
     
  3. tilawn

    tilawn Member
    Messages: 55

    yes truck was in the run posistion and even had it running. I tested the light straight to the battery and it works when I touch the wires to the posts, so my wiring is good and also when I flip up the switch in dash the little light in it lights up but the strobe does not (still confused)
     
  4. stangman35

    stangman35 Senior Member
    Messages: 267

    What about the orange/blue wire did you put a test light on it to confirm power there?
     
  5. stangman35

    stangman35 Senior Member
    Messages: 267

    also be sure you have the right orange/blue wire there is another one that has to do with PTO
     
  6. tilawn

    tilawn Member
    Messages: 55

    yes just did it a little while ago and unfortunately no power there. I was talking to someone else and they were saying something about 4 other wires up and under the hood but I have not been able to go look for them yet and dont know what to do with if I do find them
     
  7. stangman35

    stangman35 Senior Member
    Messages: 267

    The four wires under the hood are pass thru wires they are dead at either end.They are there to make it so you dont have to run wires thru the fire wall the are located near the other wires your working with under the dash.
     
  8. tilawn

    tilawn Member
    Messages: 55

    do they have anything to do with the upfitters
     
  9. stangman35

    stangman35 Senior Member
    Messages: 267

    the bundle of wires you need, there should be 2 that are about 16guage and 2 that are like 10 guage
     
  10. stangman35

    stangman35 Senior Member
    Messages: 267

    they are just there for anything you want to run on them,thru the fire wall
     
  11. tilawn

    tilawn Member
    Messages: 55

    that PTO wire should that have power to it because the wire I am using has no power to it also there are quite a few "open" ended wires under the dash but I think I only saw one orange with blue trace I am going to go check it if I can get it in the shop
     
  12. stangman35

    stangman35 Senior Member
    Messages: 267

  13. tilawn

    tilawn Member
    Messages: 55

    ok I will check that out
     
  14. stangman35

    stangman35 Senior Member
    Messages: 267

  15. tilawn

    tilawn Member
    Messages: 55

    I assuming that the wire I hooked to should then go to the fuse block and then from there to the switch in dash. What is really confusing me is there is no power at the orange with blue tracer wire when I put a light tester to it
     
  16. stangman35

    stangman35 Senior Member
    Messages: 267

    page 5 of the last PDF link shows the location and wires that you need,those four wires will have power when there switch is on and the key is on
     
  17. DCSpecial

    DCSpecial Senior Member
    from IL
    Messages: 408

    You hooked to the wire that's tucked behind the fuse panel under the dash correct?

    All 4 orange wires are taped off together to a wire loom.

    Orange w/blue should be the Aux 4 10amp switch.


    You can see all the Upfitter wires here:

    [​IMG]


    If you are hooked to the correct wire, check the fuses for the upfitters.
     
  18. mc1

    mc1 Senior Member
    Messages: 171

    i had the sameproblem with my truck CHECK THE FUSES i blew them trying to crimp all the connections . as you know its not fun working under there so much in the way anyways fuses is my guess
     
  19. tilawn

    tilawn Member
    Messages: 55

    yes I am hooked to those wires and have checked all fuses still not working I geuss I need to replace relays???? My dealership has no idea on how they work big help they are
     
  20. tilawn

    tilawn Member
    Messages: 55

    thsnkd for the help guys I figured it out. My buddy picked the wrong set of wires to hook to. Stangman35 you were correct he was hooked up to the PTO wires and not the upfitters. I figured it out with that PDF link you posted. Again thank you guys for your help