1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Unimount trouble

Discussion in 'Western Plows Discussion' started by Unimount219, Feb 3, 2008.

  1. Unimount219

    Unimount219 Junior Member
    from indiana
    Messages: 22

    Ive got an early Unimount, ive been having problems with it since i got it, after a while of plowing it decides not to go up or down only left i checkd all the connections and i cleaned the plugs changed the fluid and filter.When i put my backup unimount on there it works fine, if anyone knows what the problem is i would appriciate it.
     
  2. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Has to be an electrical issue to do what it's doing (or not doing).

    The next time it acts up put the control in the float position and check the S1 coil for magnetism. If it doesn't have mag, next check the white/yellow wire on the S1 coil with a test light to see if it's getting power. If it's not, start working you way back the harness toward the grill connectors with the test light, may have a broken wire in the harness on the plow side or the plow side grill connector is bad inside.

    Also check the ground harness and connections that run between each of the coils and over to the ground stud/bolt on the motor to be sure their clean and tight.
     
  3. Unimount219

    Unimount219 Junior Member
    from indiana
    Messages: 22

    Ok ill try that , the local plow shop said that all 3 of the valves are bad ,b but i dont see that happening. i think that something is wrong with the pump but ill do what you said.
     
  4. 02crew

    02crew Junior Member
    Messages: 19

    Sounds like the same problem I was having. The next time it acts up, wiggle the control harness on both sides of the plug in. I ended up putting on a repair harness on the truck side, and the plow works like a charm now.
     
  5. schuitb

    schuitb Member
    Messages: 95

    connection

    Hey,
    Similar issue with my plow.. I had new headlight kit put on and that comes with a new connector.. When pluging into the truck side everything worked except for the plow dropping.. a wiggle of the connector and then it dropped... A new connector on the truck side will fix this but i found that using a zip tie on the connector worked to keep the it tight....

    L8r.
     
  6. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Me either...
     
  7. Unimount219

    Unimount219 Junior Member
    from indiana
    Messages: 22

    Thanks

    Thanks alot guys, i think there is somehting wrong with the plowside harness that happend to one of my other unimounts, it has always gave me problems the plow sat in a field for about 2 yrs before i bought it. its a great plow when its working and i only bought it for 400 w/o truckside and wiring so not a bad deal. If there is anyone in N/W indiana that ever needs plows spreadrs or anything there is a good friend of mine with alot of equipment. 924-4332 Bridegroom services huge place for cheap plow parts
     
  8. snapaj

    snapaj Junior Member
    Messages: 3

    what is the area code please :)
     
  9. Unimount219

    Unimount219 Junior Member
    from indiana
    Messages: 22

    219 NorthWest indiana