1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

unimount sticky spool

Discussion in 'Western Plows Discussion' started by jimmyjam, Jan 8, 2011.

  1. jimmyjam

    jimmyjam Junior Member
    Messages: 25

    Thanks to the awesome help I received on this forum about a month ago, was able to diagnose a left angle chatter problem to a sticky spool. Was fine for a few weeks - only had to plow twice due to limited snowfall. However, problem returned today. Just wondering if this just means I need to replace the spool or if maybe there is something else that is causing the spool to stick. Thanks much in advance.
     
  2. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Did you replace the spool the first time, or just clean it up?
     
  3. jimmyjam

    jimmyjam Junior Member
    Messages: 25

    Just cleaned it up, and thought maybe it could be the spring too, so checked that. seemed ok, but not sure how stiff it really should be. thanks
     
  4. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Disassemble it again Jimmy, checking for damage or debris again if you'd like but normally it's best to just replace it after the second time around. They'll be bent ever so slightly therefore causing them to stick in the bore (intermittently) and will result in this situation.
     
  5. jimmyjam

    jimmyjam Junior Member
    Messages: 25

    Ok, thanks very much. Kinda figured that. I did take it apart again this afternoon so we'll see how long she lasts. I'm thinking you're right and I'll have to just replace it. Thanks again.