1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Unimount relays/ Blizzard relays

Discussion in 'Western Plows Discussion' started by Chiputz, Nov 2, 2012.

  1. Chiputz

    Chiputz Senior Member
    Messages: 165

    Does anyone know if the relays for a pre DD Blizzard are the same as the Western relays? I just put a unimount on my Dodge and the lights keep cutting out. The wires keep coming loose off the relays, I have to open the hood and tap the relays and everything is working again. I already cleaned all the terminals with electronic cleaner and reseated and dielectric greased them. The old Blizzard harness I have has a clip that holds 2 relays and has a base that locks the wires onto the relays. Any ideas? I have taken apart and retaped the relays 3 times already... Thanks for any input.
     
  2. dieselss

    dieselss PlowSite Fanatic
    Messages: 11,001

    Well you can get waterproof relays and waterproof relay connectors....I have put them on our top kicks and they are working good so far
     
  3. dieselss

    dieselss PlowSite Fanatic
    Messages: 11,001

    You can always just "crimp" the connectors a little more so there tight
     
  4. Chiputz

    Chiputz Senior Member
    Messages: 165

    I tried crimping them tighter, no luck. I might try seperating the clips from the blizzard relays and see if the westerns will fit the clips
     
  5. dieselss

    dieselss PlowSite Fanatic
    Messages: 11,001

    Unless you have a relay connector you should need to separate the "clips". Maybe pics?? And I meant crimp or close the connection end, not the wire end