1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Unimount Problem!

Discussion in 'Truck & Equipment Repair' started by Lovelace Lawn, Mar 2, 2009.

  1. Lovelace Lawn

    Lovelace Lawn Junior Member
    from VA
    Messages: 1

    I have a western unimount. Last night the elbow broke on the hydraulic line where the line connects in the pump. I have replaced the elbow. I did lose fluid when this happened. The motor will make a sound when I go to lift but nothing is moving. I took the plug out of the top of the motor and hydro fluid ran out. I am wondering how I can get this thing going again? Suggestions???????
  2. 24v6spd

    24v6spd Senior Member
    Messages: 615

    Will the plow angle left/right?
  3. CityGuy

    CityGuy PlowSite Fanatic
    Messages: 16,906

    drain fully rams and all and refill sounds like you've got an air lock
  4. Crash935

    Crash935 2000 Club Member
    Messages: 2,377

    You put air into the system by running it low on fluid and thats why fluid came out when you took the fill plug off. You need to remove the vent plug also, which is on the right front corner of the pump if your standing in front of it. Will be a allen wrench plug. With the blade on the ground, fill until fluid comes out the vent hole, put plugs back in and ANGLE the blade left and right without raising it. Repeat the fill process and angle the balde again before raising. May take a little time to work the air out of the system.