1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Unimount plow problem

Discussion in 'Western Plows Discussion' started by mowtivationsLLC, Dec 30, 2009.

  1. mowtivationsLLC

    mowtivationsLLC Junior Member
    Messages: 9

    while plowing last weekend the blade wouldnt raise suddenly. i checked the relay and all connections and they were all fine. i tightened the battery terminals and then tried to raise the plow and it raised enough for me to get home. the next day it lowered and raised fine. today i changed the atf fluid (with s.a.m. brand) and now it wont raise or lower yet again. the relay is clicking and the plow is "trying" to raise but it wont. does anybody have any viable solutions that can help??seems like i cant win for loosing. thanks in advance. can
     
  2. twinman326

    twinman326 PlowSite.com Addict
    Messages: 1,683

    when you change the fluid, did you clean the screen out?
     
  3. mowtivationsLLC

    mowtivationsLLC Junior Member
    Messages: 9

    no i didnt. thats what im doing now. is the screen small? i see a small screen that resembles a miniature cold air intake filter located under the moter inside but im not sure if thats the screen that needs to be removed and cleaned.
     
  4. Crash935

    Crash935 2000 Club Member
    Messages: 2,377

    Thats the screen you need to clean.

    Is it just the raise function that wont work?
     
  5. twinman326

    twinman326 PlowSite.com Addict
    Messages: 1,683

    That the one is hook up to the pump.

    You might also clean the pump housing and filter with brake cleaner, and use a air gun to blow it out. DO NOT USE A RAG INSIDE THE PUMP HOUSING.

    here is some information to bleed the system

    clean.jpg

    Do not "LIFT THE BLADE" WHEN ANGLING LEFT THEN RIGHT.. I use a hydraulic jack under the blade, and manually swing the blade left, then right, and back to center. Then I recheck the fluid for level..THEN I use the controller to lift the blade (remove the hydraulic jack from underneath the blade) and lower. Recheck the fluid for level..

    clean.jpg
     
    Last edited: Dec 31, 2009
  6. mowtivationsLLC

    mowtivationsLLC Junior Member
    Messages: 9

    thanks for all your help. i did all the above and its still not working right. @ crash, no its not just the raise that isnt working. The left and right movements wont work either. It'll work long enough for me to get it off the ground and out of my garage, but if i let it back down it wont raise again (or turn left or right) for a lil while. i dont know if it needs a new pump or a new motor. all my electrical connections are tight and well grounded. Glad we dont have any snow forecast for the next week or so.
     
  7. twinman326

    twinman326 PlowSite.com Addict
    Messages: 1,683

    you check the connection between the plow n truck for loose or broken pins??
     
  8. mowtivationsLLC

    mowtivationsLLC Junior Member
    Messages: 9

    yup. cleaned all the pins and re'greased them..nothing :-(
     
  9. KT Unlimited

    KT Unlimited Junior Member
    from NW NJ
    Messages: 6

    Just a hunch do you have a hand held remote ?

    just had some issues that didn't't lead to a remote issue but the processor went bad
    It worked in up/down left but not right through me for a loop if you have a hand held
    try a different remote (get one from a friend).

    hope it works 4 u.
     
  10. no lead

    no lead PlowSite.com Addict
    Messages: 1,308

    when you changed oil did you flush the angle cyls and put it in float and push the lift cyl all the way down? unchain the blade and see if it will lift the arm. if it will lift without the blade the pump may be weak. last, check the o ring on the bottom of the pump.
     
  11. twinman326

    twinman326 PlowSite.com Addict
    Messages: 1,683

    U check the ground (black/orange )wire from the solenoid to the negative side of the battery. Also from the S valves to the plow frame. Sometimes it might look good, you should take it off and check for rust, or an end ready to break off.

    Or try another controller..
     
    Last edited: Jan 3, 2010
  12. mowtivationsLLC

    mowtivationsLLC Junior Member
    Messages: 9

    yes i do have a handheld controller and yup i did all the other stuff above...cept borrowed another remote. all my friends have boss plows and i dont know if theyre compatible with my western. ima go out and jump it and see if the motor makes any noise. thank u all for your ideas and info. i truly appreciate you alls help.
     
    Last edited: Jan 3, 2010
  13. ringahding1

    ringahding1 Senior Member
    Messages: 260

  14. twinman326

    twinman326 PlowSite.com Addict
    Messages: 1,683

    U can jump the solenoid to see if the pump is working..Also if someone has a joystick controller that will also work to see if your hand held controller is bad.

    Here one to test the solenoid
    CRST.jpg

    Controller test
    DSCTJST.jpg

    CRST.jpg

    DSCTJST.jpg