1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Unimount plow lights

Discussion in 'Western Plows Discussion' started by rico, Dec 15, 2008.

  1. rico

    rico Member
    Messages: 40

    I have an Unimount pro plow that has been on this truck for a couple of years. This year when I hooked up the plow, the plow lights will not light. The truck lights stay on. Is a relay burnt out or is the drl module burnt out (Chevy)?

    Thanks.
     
  2. Philbilly2

    Philbilly2 2000 Club Member
    Messages: 2,592

    check the realys. it sounds like a relay not clicking over
     
  3. rico

    rico Member
    Messages: 40

    The marker light connector was rusted and not getting a good connection

    Thanks
     
  4. ront8261

    ront8261 Junior Member
    Messages: 3

    I've got the same issue with a Unimount on a 2002 Chevy K2500. Can you be more specific about where the problem was with the Marker lamp??? I'd read that its the marker lamp connection, or something like that, that detects whether to energize the relays to switch to the plow lights, but not sure where to look for that problem. I know all the relays and connectors are behind the Drivers side truck headlight.
     
  5. Dodge Plow Pwr

    Dodge Plow Pwr Senior Member
    Messages: 568

    There is a wire that connects to the marker light that comes out of the plow wiring harness. I think it was on the drivers side of the vehicle. I had the same problem a few years back, but I also had a relay problem with the wire corroded in the splice. You really couldn't see it by looking at it.
     
  6. Crash935

    Crash935 2000 Club Member
    Messages: 2,377

    On the 02 there will be a seperate relay for the marker lights. Check the connection right behind the drivers side marker light assy (brown wire). At the relay (with marker lights on) check for power on terminal 86 (should be brown wire here also). Should also have power on terminal 30 (tan wire).
     
  7. ront8261

    ront8261 Junior Member
    Messages: 3

    Thanks Crash!! That was the type of detail I was looking for. I'll check that out.
     
  8. ront8261

    ront8261 Junior Member
    Messages: 3

    That was it!! Found brown out of marker light and checked it for power. OK. Changed that relay and all is well with the lights now!! Your details helped me figure out what I needed to look for in that rats nest. Thanks!!
     
  9. CityGuy

    CityGuy PlowSite Fanatic
    Messages: 16,989

    IF your vehical lights are staying on then replace both of your relays. It is the relays. I have had this problem many times.
     
  10. Crash935

    Crash935 2000 Club Member
    Messages: 2,377

    Glad you got it fixed.

    Dont you just love that mess of wires and relays? Go to westerns site and download the schematics for your harness, makes it alot easier when trying to troubleshoot the lighting issues.