1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Unimount on Dodge question

Discussion in 'Western Plows Discussion' started by Mowman62531, Dec 6, 2005.

  1. Mowman62531

    Mowman62531 Member
    Messages: 95

    Ok. I finally received the right wiring harness from the dealer and stuck it in the 98 Dodge 2500 tonight. Still no luck! Now the plow lights come on when the light switch is pulled on one click when I should just have parking lights. My dim lights on my plow come on when the high beams should be on and the high beams come on when my dims are supposed to be on. I think this is just a relay wiring problem. Does anyone have a pic from a manual or something to show how these relays should be wired? I would really appreciate the help! By the way, I downloaded a schematic off of Western's web site and it only shows two relays wired it and I have four.
  2. PaleRider

    PaleRider Senior Member
    Messages: 112

    Do you have the Right schmatic??

    :waving: Hi Ron,
    Do you have the right schmatic?? I've done that twice already. I've looked up information only to find that I've printed the wrong info. :realmad:

    PaleRider :gunsfiring:
  3. Mowman62531

    Mowman62531 Member
    Messages: 95

    Actually, I have printed out everything off of the Western website. I figured it would be nice to have in a three ring binder with me on the route if something goes wrong on one of the trucks.
  4. Crash935

    Crash935 2000 Club Member
    Messages: 2,377

    Hate to say this but, the 98 dodge harness only has 2 relays, you should have gotten the 62525 harness kit, sounds like you have the 62917 kit which fits the 99-02.
  5. bcf

    bcf Senior Member
    Messages: 206

    Yeah, you should be following a schematic for two relays. I did the same thng about aweek ago. The harness should be the same, just no need for the jumpers or two red wired fuses. Check which one you were following. On my '97, I have HB1 headlights, the same bulb for the highs and lows. When I hooked up four relays, my lights did the same as yours, except the high beam turned all lights off.
  6. SnowGuy73

    SnowGuy73 PlowSite Fanatic
    Messages: 24,868

    Check your relays.