1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Unimount old slow pump fix ???

Discussion in 'Western Plows Discussion' started by mossman381, Feb 15, 2010.

  1. mossman381

    mossman381 2000 Club Member
    Messages: 2,410

    I have an old 7'6" western pro plow. The last few days the plow will only raise an inch or so off the ground. It angles good. I might have to use the plow so I took another pump that I had for another project and put it on my plow. All I can say is wow. That old pump moves so slow compared to the new pump. My question is what is wore out in the old pump that it does not raise and is slow? I cleaned the screen inside and have put clean blue fluid in it. Would a new pump fix it or maybe new valves. I am not sure what else would wear out causing this. This plow is very old and I think the pump is original. I am thinking maybe 20 years old. I would like to fix the old pump so I have another good spare.
  2. RepoMan207

    RepoMan207 PlowSite Fanatic
    from Maine
    Messages: 5,031

    I would completely flush the system first, but I would say your over due for a new pump.
  3. mossman381

    mossman381 2000 Club Member
    Messages: 2,410

    Is there a way to test the pressure?
  4. twinman326

    twinman326 PlowSite.com Addict
    Messages: 1,683

    Yes with a pressure gauge (2000 psi)



  5. mossman381

    mossman381 2000 Club Member
    Messages: 2,410

    Thanks for the help guys.