1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Unimount Lights DO NOT WORK!!! 99 Superduty

Discussion in 'Truck & Equipment Repair' started by Snow2Go, Jan 10, 2009.

  1. Snow2Go

    Snow2Go Senior Member
    from Chi
    Messages: 223

    Ok bought a complete used unimount with everything, We did everything correct even checked the Wires for each relay, even tried different relays and they do not click when you turn the headlights on and only the factory lights go on, not the plow lights. Anyone? :cry::cry:
     
  2. basher

    basher PlowSite Fanatic
    from 19707
    Messages: 8,992

    Do you have parking lights? Where are you gounding the unit?
     
  3. Snow2Go

    Snow2Go Senior Member
    from Chi
    Messages: 223

    I do not have the parking lights hooked up because we dont use them Grounding to the battery.
     
  4. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    The head lights wont switch between the truck and plow no matter what you do if the parking light wire isn't connected, as thats what trips the relays. :waving:
     
  5. Snow2Go

    Snow2Go Senior Member
    from Chi
    Messages: 223

    You positive?
     
  6. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    100% ;)

    Standard procedure on the Uni's, REQUIRES the parking light feed to activate the relays.
     
  7. no lead

    no lead PlowSite.com Addict
    Messages: 1,308

    extremely.
     
  8. Snow2Go

    Snow2Go Senior Member
    from Chi
    Messages: 223

    Thanks guys, that was it.