1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Unimount fluid leak between solenoid body and housing

Discussion in 'Western Plows Discussion' started by 6kxj, Jan 3, 2011.

  1. 6kxj

    6kxj Junior Member
    from nwct
    Messages: 1

    I cannot stop the leak between the electric solenoid body and reservoir. both surfaces are clean and smooth and are sealed with 3 o-rings using 3 bolts. i have replaced the orings a few times and spoke with a dealer who said the bolt holes could have been drilled to deep in the the reservoir. I was advised to also put orings around the bolts too. this did not help. teflon tape did not help, no cracks or warpage found. has anyone had this problem. If so please help with a fix if you have had any luck. thanks
  2. affekonig

    affekonig Senior Member
    Messages: 909

    I had the same leak and it was the o rings. Are you sure the ones you relaced them with are the right size and that they stayed in place when you put it back together? There's isn't too much going on there that could be leaking, so fixing it shouldn't be too bad. Good luck.
  3. randomb0b123

    randomb0b123 PlowSite.com Addict
    from america
    Messages: 1,278

    i think im having this same problem. where do i get these o rings?
  4. Sharpcut 1

    Sharpcut 1 Senior Member
    Messages: 386

    One O-ring is bigger than the other 2, make sure they are in the right holes. Also agree about Using ONLY western O-rings. Ask me how I found out:eek::eek:
  5. randomb0b123

    randomb0b123 PlowSite.com Addict
    from america
    Messages: 1,278

    where do i find them?