1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

uni mount wont angle or drop

Discussion in 'Western Plows Discussion' started by Red Ross, Mar 3, 2007.

  1. Red Ross

    Red Ross Junior Member
    Messages: 17

    plow wont angle to the right or drop took the cartridge's out and cleaned them and it worked for a few times and stopped and also tried new/used and does the same thing
     
  2. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Where you angle right and lower function's don't work, did you check to see if you have power at the S1 (drop) and S2 (angle right) coil's when operating those function's? Does the angle left function work, even when the other two don't? Also. most of the time when you have problem's with the Unimount's it's a poor connection at the grille connector so be sure and check/clean them too.
     
  3. Red Ross

    Red Ross Junior Member
    Messages: 17

    cleaned the grill connecters, have power and ground at s1 s2 and s3 also tried different cartriges and coils on all 3. Plow does work going down now but still wont angle right the truck works with back up plow
     
  4. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    If the valves/coils are operating then the only other thing in the hydraulic system that could prevent it from angling to the right is the poppet check valve in the valve block. I'd pull it out and check/clean it. Do you have the Western manual for your plow to determine where the poppet's are located?
     
  5. S & A Landscaping & Plowing Service

    S & A Landscaping & Plowing Service Senior Member
    Messages: 100

    This just happen to me about 2 weeks ago...Took it in and thy had to replace controller...cost me 200.00 Good luck with it....
     
  6. Red Ross

    Red Ross Junior Member
    Messages: 17

    Any other ideas replaced poppet valves, rellieve valves, cartridges and coils and have power and ground. plow worked for about 10 min. after cleaning and replacing parts and does the same thing agian
     
  7. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    When you try and angle it to the right, does it sound like the pump is straining against the pressure relief valve (like when you lift it all the way up but don't let off the control right away) or does it just sound like it's free flowing with little resistance?
     
  8. Red Ross

    Red Ross Junior Member
    Messages: 17

    Yes the pump is running and makes the same sound as if you lifted it all the way up
    I'm starting to wonder if the valve manifold is bad if anyone has a used inexpinsive one for sale let me know
     
  9. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Is the plow now stuck all the way left? I assume it is since you can't angle it right. Before I'd condemn the manifold, I'd disconnect both the angle hoses and see if you can manually angle the blade, as it is possible one of the pistons is sticking inside the angle cylinder (not to common though but it does happen). The other thing I'd do is remove all the valves/hoses/check valves from the manifold and clean it and blow it all out with compressed air as theirs really nothing inside the manifold itself to go bad.
     
  10. Red Ross

    Red Ross Junior Member
    Messages: 17

    I tried to manually get the blade to go right by pushing a pile but still wouldent move so I reversed hoses at the manifold and it seems to be working. Plowed with them reversed for half hour then put them back I must have had dirt in one of the valves Still plowed with back up plow last night so I wouldent have trouble thanks for the help (By the way three years ago I did have a manifold block go bad but that was under warrenty parts alone were $600.00 at the time)
     
  11. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Hmm,you must be a lucky guy,:) as theirs no logical reason why swapping the hoses would fix the problem.