1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Uni mount Wire plugs (circuit?)

Discussion in 'Western Plows Discussion' started by lawnsrusinc., Dec 7, 2010.

  1. lawnsrusinc.

    lawnsrusinc. Senior Member
    Messages: 141

    Are the wire plugs on the plow side and truck side have circuits in the plugs cause when i twist the wires the plow works. Any ideas can i make my own wire harness or do i have to get robbed by the dealer.
     
  2. no lead

    no lead PlowSite.com Addict
    Messages: 1,308

    spray both sides of the plugs with brake cleaner. face the plugs up so the cleaner stays in the plugs for a few minutes and spray them again. then blow out with compressed air.

    give that a try. if not i can get the replacement plugs pretty reasonable.
     
  3. twinman326

    twinman326 PlowSite.com Addict
    Messages: 1,683

    Also if your "twisting" the wires, there might be a break in one of the wire, or the prongs are not making full contact..
     
  4. lawnsrusinc.

    lawnsrusinc. Senior Member
    Messages: 141

    I ended up just taking all the wire out and replacing the plugs and wire cleaned up the grounds and it was good. I seen a little crack in the one post on the plug. Iam up and running and ready for more snow
     
  5. twinman326

    twinman326 PlowSite.com Addict
    Messages: 1,683

    Glad you found the problem..Happy plowing