1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

uni-mount speed

Discussion in 'Western Plows Discussion' started by ajordan193, Feb 7, 2008.

  1. ajordan193

    ajordan193 Senior Member
    from WNY
    Messages: 224

    Is there anyway to speed up a uni-mount?
     
  2. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    The straight blade Uni's were fairly fast in there day. If it seems slower than normal then it may either need some maintenance (fluid/filter cleaned, cables/connections cleaned) or the pump motor or truck battery are getting tired.

    Some good maintenance and an amp test to determine motor/battery health will bring them back to their former glory.
     
  3. oman1999

    oman1999 Senior Member
    Messages: 198

    Good speeds on a conventional uni-mount with all ne components and dual batteries:

    2 sceonds to full raise.

    3 seconds from full left to full right.

    That is the best I've gotten.
     
  4. ajordan193

    ajordan193 Senior Member
    from WNY
    Messages: 224

    thanks guys, i changed the fluid at the beginning of the season. Where is the filter located?
     
  5. sechracer

    sechracer Senior Member
    Messages: 478

    Filter is inside the pump housing, on the side of the actual pump. You will need to drain it and pull the motor off.... Once you do that, if you look down into the housing, you will see the pump and the filter attached to the side of it.