1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Ultramount won't lower

Discussion in 'Western Plows Discussion' started by dave00diesel, Jul 23, 2010.

  1. dave00diesel

    dave00diesel Junior Member
    from indiana
    Messages: 21

    Was moving the plow today only to discover when I was ready to unhook it that it wouldn't lower. I put the light green wire onto the terminal for the white/yellow wire is supposed to be (2W coil). I was then able to lower the plow by using left/right on controller. I would assume that would mean the coil and valve are both fine and working. Any other suggestions? Possibly bad controller? Thanks for any help.
  2. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Check for power on the white/yellow wire right at the coil with the controller in float (ignition on of course). I think you find it has none. If it doesn't, start at the grill plug checking for corrosion/missing pins/continuity and then check right at the controller plug on the same white/yellow wire. If you don't have it there then the controller is the fault.

    If you have it at the controller but not at the grill plug start over the under hood wiring looking for corrosion/abrasion. But most likely it's in the grill plug.