1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Ultramount won't lift.....

Discussion in 'Western Plows Discussion' started by PackMan12, Nov 12, 2011.

  1. PackMan12

    PackMan12 Junior Member
    from Chicago
    Messages: 3

    I have a 7 1/2 foot Ultramount that won't lift or pivot. I changed the solenoid and can hear it click when I try to raise it. From what I can see all wiring is good along with grounds. Any advice is much appreciated.

    -Kris
     
  2. Tony350

    Tony350 Senior Member
    Messages: 546

    Check to see if you are getting power to the motor. If you are an d the motor isn't spinning then the motor is shot. You can try and put jumper cables directly to the battery and the motor and see if it spins if you are by your self.
     
  3. mishnick

    mishnick 2000 Club Member
    Messages: 2,243

    Just put a test light on the motor terminals, if the ligt comes on but the motor doesn't spin then chances are the motor is toast. But if the motor doesn't turn but your vehicle lights seem like they are dimming as if there is a big load on it your pump could have had a catastrophic failure and is stopping the motor from turning. Sometimes if the motor brushes are on their last legs you can get someone to tap on the motor with a soft hammer while another hold the lift button on the controller. Tapping it can move the armature just enough to get it to make contact with the worn brushes and make it go again.
     
  4. PackMan12

    PackMan12 Junior Member
    from Chicago
    Messages: 3

    Thanks guys! I really appreciate it.