1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

ultramount problems

Discussion in 'Western Plows Discussion' started by skippy645, Dec 6, 2010.

  1. skippy645

    skippy645 Junior Member
    Messages: 4

    Does anyone know how the body control module on my 06 dodge ram might keep my ultramount from powering up. I have taken it to my local dealer, where I bought the plow, they tested the iso module, and told me that i had power to the module, but none out. They ordered a new iso module. I plugged it in and nothing was different, I have checked all the grounds, fuses, and connections and the only thing I have questions about is how and if the body control module on my truck might be the culprit?
     
  2. no lead

    no lead PlowSite.com Addict
    Messages: 1,308

    body module no. the plow only see's 12 volts. the module wont know if there is a plow connected or a cd player. should not matter. find the red wire under the dash for the plow. supply it with power from the battery. did it turn on?
     
  3. skippy645

    skippy645 Junior Member
    Messages: 4

    We did jump the red wire last week and the hand control did light up. It seems as though the red lead has power when I check it in the engine compartment, but if I go inside the truck, I don't get any power at the plug under the dash for the hand control. Any help is greatly appreciated, thanks!
     
  4. twinman326

    twinman326 PlowSite.com Addict
    Messages: 1,683

    Move the red wire to another location in the fuse box.Don't forget you only want power when the key is turn on. Use a test light to locate a tab that has power only when the key is turn on and move the red wire to that power tab.
     
  5. skippy645

    skippy645 Junior Member
    Messages: 4

    I will see what happens tomorrow am. What is the purpose of the red wire? thanks!
     
  6. twinman326

    twinman326 PlowSite.com Addict
    Messages: 1,683

    Check to see if the red wire going through the fire wall is damage
     
  7. no lead

    no lead PlowSite.com Addict
    Messages: 1,308

    the red wire turns the control on. make sure the black/orange wire is hooked to the negative side of the battery under the hood.
     
  8. skippy645

    skippy645 Junior Member
    Messages: 4

    Hey guys, thanks for taking the time to help me...I just figured the problem out yesterday and thought you might like to hear what the problem was. I went back over the harness and found that I was getting an intermittent connection of the ground where the plugs are at the plow. The ground loops around there and completes the circuit. Without that ground, the module won't power up. WHAT A RELIEF!...Thanks again!