1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

UltraMount Lift Cylinder

Discussion in 'Western Plows Discussion' started by MarkEagleUSA, Dec 21, 2013.

  1. MarkEagleUSA

    MarkEagleUSA Senior Member
    Messages: 321

    I replaced my lift cylinder today and can't seem to get it bled properly. There's a definite "soft" spot when I put the plow into float. The last inch or 2 of downward travel feels like an air pocket.

    I tried several up/down cycles followed by cracking open the line at the cylinder (with the cylinder both up and down) and still can't get rid of that air pocket.

    Is there a trick to bleeding this cylinder or do I just have to wait for it to work itself out?
     
  2. dieselss

    dieselss PlowSite Fanatic
    Messages: 11,003

    Wait, sometimes its normal, And are you cracking the fill plug loose as well?
     
  3. MarkEagleUSA

    MarkEagleUSA Senior Member
    Messages: 321

    Opened the fill to check the level... didn't notice any air escaping though.

    I'll check it later this morning since it's been sitting since yesterday afternoon.
     
  4. dieselss

    dieselss PlowSite Fanatic
    Messages: 11,003

    Ok. Level should be right at the threads, FYI
     
  5. MarkEagleUSA

    MarkEagleUSA Senior Member
    Messages: 321

    Yup... that's what I was checking for. I checked it earlier today and there's still a little air trapped in the cylinder. The spongy travel seems to be about half of what it was yesterday. I'll give another day or 2 and see what happens.
     
  6. dieselss

    dieselss PlowSite Fanatic
    Messages: 11,003

    Ok. Sometimes they take forever to bleed