1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Ultramount angle problem

Discussion in 'Western Plows Discussion' started by obrut, Dec 10, 2008.

  1. obrut

    obrut Senior Member
    from IL
    Messages: 149

    I have a 7.5 ultramount pro poly with a hand held control and this seems to happen more and more lately. Here is the probelm, if the blade is in the air and just about straight, if I press left on the controller sometimes it will go right first, then jolt, then go left. It does it to the right sometimes too. Up and down works fine and I haven't noticed any other problems. I did a search but don't have enough time to read through everything, thanks for any help.
     
  2. no lead

    no lead PlowSite.com Addict
    Messages: 1,308

    normal for a handheld.
     
  3. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Only if it's failing. Not normal otherwise.


    Your S3 valve is slow to open for one reason or another. Does it ever hesitate to raise as well? In other words when you press the raise function has it ever strained against the pump for a second..and then raised?
     
  4. obrut

    obrut Senior Member
    from IL
    Messages: 149

    B&B, no never a problem raising up.

    Tim
     
  5. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    If it never misses a beat on the raise function then it's a controller issue. They usually die completely or get worse not too long after that. ;)
     
  6. infineon954

    infineon954 Senior Member
    Messages: 235

    Take it apart and under the red rubber part there are metallic contact pads. Clean them off with some alcohol and then see what you have. Just a suggestion.