1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Ultra mount wont turn left or right when raised

Discussion in 'Western Plows Discussion' started by Dstosh, Nov 30, 2009.

  1. Dstosh

    Dstosh Senior Member
    Messages: 534

    Have a older ultra mount. It will go left and right on the ground but it wont move when it is raised. There is some play in the blade side to side( It will move a bit with out the angle cylinders moving)

    Thanks

    Derek
     
  2. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Good chance you have a faulty controller.

    After you lower the blade, very quickly bump the raise function without actually raising the plow at all. If it will then angle then the controller is bad.
     
  3. Philbilly2

    Philbilly2 2000 Club Member
    Messages: 2,633

    I have that problem from time to time. I have to get out of the truck and wiggle the harness as I am not reciving a good connection on my truckside to plowside harness
     
  4. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Then fix it. :D
     
  5. Philbilly2

    Philbilly2 2000 Club Member
    Messages: 2,633

    Yeah, I just can't bring myself to spend the money on new harnesses.

    So duct tape and baling wire is not fixing it?? :eek:
     
  6. infineon954

    infineon954 Senior Member
    Messages: 235

    Sounds like a bad solenoid.
     
  7. twinman326

    twinman326 PlowSite.com Addict
    Messages: 1,683

    Then fix the break in the harness.......

    Had the same problem last year.....wiggle the plow harness I would loose the lights....wiggle it again the lights came back on...Cut the casing around the harness, found the break, repair it, and tape were I cut the casing....No problem after that......still working.......
     
    Last edited: Dec 7, 2009
  8. got-h2o

    got-h2o 2000 Club Member
    Messages: 2,439

    Not if it raises. The soleniod doesn't control function, it supplies power to be able to use the functions. If it does one, it would do the other. ;)
     
  9. twinman326

    twinman326 PlowSite.com Addict
    Messages: 1,683

    also could be a bad pin in the harness plug..
     
  10. Dstosh

    Dstosh Senior Member
    Messages: 534

    I think it is a broken wire in the truckside harness. When you wiggle the wires it works. I bought It used so i suspect thats the problem. I just put a new controll harness on the plow side.