1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Ultra mount slow to angle left

Discussion in 'Western Plows Discussion' started by dm5.9, Dec 24, 2010.

  1. dm5.9

    dm5.9 Member
    Messages: 59

    Hey Everyone,

    I tried to search but could only find info on the older cable mounts, anyway.

    I drained and replaced the fluid in my ultra mount western straight plow, and now it seems that when i angle to the left its really slow, way slower then when it goes right. I drained all the fluid out of all the rams and the pump, and refilled with the stuff from angelos supply. It was blue hydraulic fluid.

    Any ideas what I can check? It was fine before changing the fluid

    Thanks Alot
     
  2. twinman326

    twinman326 PlowSite.com Addict
    Messages: 1,683

    did u swing the plow manually left..... right to get the air out of the rams?

    Is the fluid level correct?
     
  3. dm5.9

    dm5.9 Member
    Messages: 59

    I manually angled it both left and right to get the fluid out then refilled it an angled it each way topping it off inbetween then filled it to the bottom of the fill port
     
  4. PlowinMD

    PlowinMD Junior Member
    Messages: 12

    I've had the same problem. The valves are dirty and they need to be replaced. Go check the manual, I don't have a copy in front of me right now.
     
  5. twinman326

    twinman326 PlowSite.com Addict
    Messages: 1,683

    Did you check and clean the suction screen?

    The S2, and S3 control the left angle.. You might want to take them out and check to make sure the valves are spooling(movement), and check the passage way to make sure there no blockage..

    Here is some info to test the S valve
    isctisct.jpg

    Merry christmas

    isctisct.jpg