1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Ultra mount Fog lights on 07 dodge ram not working

Discussion in 'Western Plows Discussion' started by roket77, Dec 5, 2011.

  1. roket77

    roket77 Junior Member
    Messages: 18

    I had my ultramount on my 07 Dodge Ram for 3 years and everything was working fine. Last winter,right before the season ended, i noticed my fog lamps on the truck wont work. This is with plow off but the wiring for lights goes through isolation module. I did take it to dodge dealer thinking it was a truck issue but they told me it was probably something to do with the plow. They said they did check it over and found nothing wrong. I heard it could be within the isolation module. It is a 4 port module but i dont know how it can be tested to see if its the module itself or something other than that. I do like driving with fog lamps and really would like this to get fixed. Any suggestions? My friend with a few western plows does know some about the system and said unplug each plug one at a time on isolation module to see if they will come on by bypassing it. No Luck. Any help is appreciated. Thanks,,
  2. 06Sierra

    06Sierra PlowSite.com Addict
    from Maine
    Messages: 1,328

    Have you checked the fuses? Under the hood too?
  3. mishnick

    mishnick 2000 Club Member
    Messages: 2,243

    The fog lights are not associated with the plow or the isolation module at all. Your mechanic clearly doesn't know anything about Western plow systems and is just using it as an excuse to avoid troubleshooting the fog lights. The isolation module simply detours power from the headlights to a relay that switched it between the truck and the plow. The signals and marker lamps are connected in parralel. Nothing, absolutely nothing, on the plow connects to the fog lights. When I install a plow on a truck with fog lights in the bumper I disconnect them while the bumper is off and it is possible that the fog lights don't work if you forget to plug them back in. But if they worked and then quit you have a truck wiring problem.
  4. roket77

    roket77 Junior Member
    Messages: 18

    Thank you for your posts. It was Dodge dealer that told me it was within the plow system. I told them to check multi function switch in steering column. Bright lights shut off fog lamps. There were two times when bright lights wouldnt come on until i lifted steering wheel to higher position but dealer dismissed that. i will have another mechanic look at that. Fog lamps automatically go off when brights are on. I was thinking at first there was something within the plow system that was "thinking" that the brights were on which would turn fogs off. Thanks for your replies.