1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Uh oh...

Discussion in 'Commercial Snow Removal' started by SlimJim Z71, Dec 12, 2000.

  1. SlimJim Z71

    SlimJim Z71 PlowSite.com Addict
    Messages: 1,031

    Went out a little while ago to go dig one of my fellow workers out of his driveway, turned my headlights on, and the truck headlights turned on... not the plow lights. Ok, so I just drive with the plow low enough so I can see. Half way there, the headlights shut off completely for about a minute, and then switched over to the plow lights. Sounds like a sticky relay or solenoid to me. Does that sound about right to you guys? I'm gonna take it in first thing in the morning, warranty claim. I've had so many problems with the place that put my plow on. This is really getting irritating.

    -Tim
     
  2. GeoffD

    GeoffD PlowSite.com Veteran
    Messages: 2,266

    Your in the auto mechanics field right? The best thing you can do is uninstall all the plow light wiring on the truck and redo it. See if you can do it after hours at your work. Some plow installers just slap the plow on, which equals problems, or they can't keep up with the more complicated electrical wiring. The third option is go back to the old plow light system, that is really simple.

    Geoff
     
  3. SlimJim Z71

    SlimJim Z71 PlowSite.com Addict
    Messages: 1,031

    This is the same place that left five of the main bolts loose on my truck-portion of the plow mount. Can you imagine what would've happened if I didn't catch that one?

    As far as re-wiring it, yes I could, but we're expecting more snow tomorrow, and again on friday (I think). Not sure if I'll have time.

    I'm gonna run someone through the ringer tomorrow!!!

    -Tim
     
  4. thelawnguy

    thelawnguy PlowSite.com Addict
    Messages: 1,011

    Id guess they did not use dielectric grease when they installed the wiring.

    Do as Geoff says dont forget the grease on all.
     
  5. SlimJim Z71

    SlimJim Z71 PlowSite.com Addict
    Messages: 1,031

    Actually, I put dielectric grease in all the connectors that I saw.

    -Tim