1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

two things wrong at once

Discussion in 'Ford Trucks' started by texdiesel, Nov 17, 2004.

  1. texdiesel

    texdiesel Junior Member
    from texas
    Messages: 12

    I own a 2000 F350 4x2 crew cab with 82000 miles. My emergency brake cable broke where it is attached at the pedal. Is this something I can replace myself and how expensive will it be. The second thing is last night I noticed that the engine upon starting cranked a little slower than normal. On the way home I checked the alternator gauge which was showing normal. This morning I went to crank up the motor and the engine would crank sluggishly but would not start. Tonight I looked at the batteries and one of them shows to have gone bad. I attempted to start the truck by placing jumpers first on the bad battery, then on the good battery. The engine would crank but did not start. Can you tell me what the problem is?
     
  2. Stark_Enterprises

    Stark_Enterprises Senior Member
    Messages: 318

  3. Mebes

    Mebes Senior Member
    Messages: 391

    I assume you were looking at the little eye on the battery that shows good or bad by changing color.
    I've never actually seen one of those work.

    If your batteries are more than 5 years old you will need to replace them.
    Keep in mind that if you bought this truck used it might have been sold in 1999.
    And don't replace just one, replace them both.
    Or the older batt will suck down the newer one.
    Figure about 3-4 years battery life if you are plowing down there in Texas.

    It is extremely hard to jump start a 7.3 powerstroke engine.
    I'm not sure what you were using to jump it but you would probably need to sustain about 450 amps to crank it over (warm)

    Pull your batteries and have them load tested, or charge them up overnight and put a volt meter on them and see if the voltage drops below 9.5V while the starter is engaged (if they do then replace them).

    Hope this helps.
     
  4. MickiRig1

    MickiRig1 PlowSite Veteran
    Messages: 3,617

    If you use your parking brake a lot

    If you use your parking brake a lot I would recommend replacing it with a Ford OEM part or OEM supplier part. In my experience with the parking brake cables the OEM's last and work the best. Cheaper is not always better some times. The cheap cables will freeze up / rust way up inside the housing. Then you end up hack sawing the cable to get the truck to move when it's
    -10 out. (I have had to do it 3 times)
    To get it off:
    You have to back off the tension on the back 2 cables at the equalizer link where all 3 come together. Then you should be able to get the new front on. Buy a book on your truck they are like $15 at an AutoZone type store.
    It will explain the procedure. The cable can run from $50 ---> $80 depending on truck size/front/ back --> long or short ones.
     
  5. Plow Meister

    Plow Meister PlowSite.com Addict
    Messages: 1,174

    The hard start issue could also be the result of a bad starter motor. They usually start to go bad at 100,000 miles. Sooner if they are exposed to more severe elements like rain, snow, mud. A bad starter will not take a jump at all. The thing with PSD's is they wiill not even inject fuel unless the engine is spinning at 500 rpm's.