1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Turn signal relay buzzing

Discussion in 'Boss Plows Discussion' started by pitrack, Feb 25, 2013.

  1. pitrack

    pitrack Senior Member
    Messages: 268

    Hey guys I recently put in HID's in my 2012 Ram. Everything works fine. However, when I turn the truck on, and turn the headlights on my relays for the turn signals on the plow wiring start buzzing, but only when my truck is on and the "headlights" are on. This is with no plow hooked up. They didn't buzz before I had the HID's in.

    I believe I have the "Yellow and purple" wires hooked up correctly. I have the yellow wire spliced into the white/blue wire, and the purple into the white/green wire behind the drivers side headlight. I just took out one of the relays and the buzzing stopped and the lights work fine. I am going to go try hooking my plow up and make sure all the parking/turn lights work correctly.

    Dumb question, but do I need that relay in there or will I harm something if I don't have it in?
    Thanks guys
  2. ihdriver7088

    ihdriver7088 Senior Member
    Messages: 315

    the actual turn signal relay harness is required on the new trucks as they cannot handle the load of the 2 extra bulbs in the plow the only alternative is to change all turn signal bulbs into led bulbs as they have such a minimal load we did this on a friends 2012 king ranch just to avoid cutting and splicing wires

    heres a link to the ebay item i purchased

    Last edited: Feb 25, 2013
  3. pitrack

    pitrack Senior Member
    Messages: 268

    Thanks man! I might try that if the buzzing doesn't go away. I hooked up the plow today and with my parking lights on, only one parking light was lit on the plow, and no buzzing. With my headlights on, it buzzed but both parking lights were lit. Then I turned the left turn signal on and the right signal flashed on the plow. I'm thinking something obviously got crossed but would that cause my buzzing issue when the headlights are on?
  4. ihdriver7088

    ihdriver7088 Senior Member
    Messages: 315

    ive noticed on my old chevy that a very light surge comes thru from the aftermarket hid lights from ebay that i have and everytime i turn mine on i have to unplug and plug my ipod back in on my radio to work correctly

    so your could have possibly back fed into the relay and fried it??
  5. pitrack

    pitrack Senior Member
    Messages: 268

    Interesting. I have a feeling it's something from the hids since I didn't have the problem before the hids were in. I would think if the relay was toast it wouldn't make a sound and just not work, instead of buzz.

    I'm going to fix whatever wire is crossed but I really don't think that will fix the buzzing mainly because it didnt buzz before the hids were in.

    I just hope if I go the led route it doesn't mess something up.