1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Turn Signal Problems

Discussion in 'Boss Plows Discussion' started by jversagejr, Jan 15, 2008.

  1. jversagejr

    jversagejr Junior Member
    Messages: 14

    I currently have an 06 Dodge Ram 2500with an 8.2 V Plow and recently I am having problems with the turn signals. At times I have either have both signals, or I have only the right or I have nothing at all. I checked all of the connections and the relays and I didn't find any problems. I figured the problem must be in the turn signal lever but when I took the truck to the dealer they told me the problem is in the plow wiring as it is sending mixed signals to the trucks computer.

    Does anyone have any ideas?
     
    Last edited: Jan 15, 2008
  2. ProSeasons

    ProSeasons Senior Member
    Messages: 624

    What about your ground?
     
  3. jversagejr

    jversagejr Junior Member
    Messages: 14

    I checked the ground and all the relays and there are no problems
     
  4. DJ Contracting

    DJ Contracting PlowSite.com Addict
    Messages: 1,392

    I had a similar problem this year with mine and found that the bulbs in the plow were shot and the filament were touching the running light filament this caused my turn signals to work weird.