1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

turn signal problems

Discussion in 'Boss Plows Discussion' started by steeltreaters, Feb 18, 2011.

  1. steeltreaters

    steeltreaters Junior Member
    Messages: 1

    i have a 2009 ford f250 with a boss 9'2'' v xt i can not get my front turn signals to work on the plow or on the truck even when the plow is off the truck. Everything worked fine prior to putting the new plow on. My mirror signals work as do my rear signals, they just blink fast. I checked the bulbs and they are fine, any ideas?
  2. BOSS_JG

    BOSS_JG Senior Member
    Messages: 194

    When you connect the Boss 13-pin truckside harness onto a vehicle, there are three wires that must be connected to the vehicles Turn/Park circuit. The Pink wire connects to the Passenger side turn signal, the Yellow wire connects to the park(marker) lights, and the Violet wire connects to the Driver side turn signal.

    For most vehicles this is all that is required to connect the Turn/Park circuit to the plows lights. But on your 2009 F250, you will also need to install a Turn Signal Relay Kit (MSC09991). This is required because your trucks turn signals are controlled by a SPDJB module, and the module will detect the excessive draw from our plows turn signals. By installing the Turn Signal Relay Kit, you supplement the turn signals with battery power, and the module does not detect excessive draw.

    So to correct your problem, install a Turn Signal Relay Kit. If you do have one installed, make sure it is wired properly. Our instructions are available at www.bossplow.com or feel free to contact our Technical Service Department at 906-776-3500, and we would be happy to assist you.
  3. 90w250mm

    90w250mm Member
    from indiana
    Messages: 42

    All of my lights initally started out just fine, after 3 events...i now have right turn signals, but the left turn light on the tower does not work and the left turn light on my truck stays on bright. Once the plow comes off the truck, everything works just fine, I am going to hook plow up to another trucks to see what issue is and go from there, unless you have any ideas..........Thanks in advance
  4. lowcostlawns

    lowcostlawns Junior Member
    Messages: 28

    Any luck on getting the front turn signals to work??

    How do you reset the SPDJB module.

    I negleted to install the extra relay and my module freaked out and killed my front turn signals!

    Any help would be great!

    I have a 2009 F250.