1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Turn Signal Problems......again

Discussion in 'Boss Plows Discussion' started by bltp203, Jan 29, 2009.

  1. bltp203

    bltp203 Senior Member
    Messages: 484

    Well I got fed up trying to figure out why the turnsignals wouldnt work. I narrowed it down to the metal bulb holder having a lousy connection. So, I ordered 2 new signals and things were great for the first few storms. Now the left side is shorting out again. When I jiggle the holder around, the problem goes away. I thought about taping the holder down, but then the housing will not fit into the lens.

    Because I own a Dodge, my "lampout" light and chime are constantly going off, driving me crazy.

    Is it possible to solder the bulb holder down?

  2. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Did you crimp the terminals slightly on the turn and maker wires before you inserted them into the new lights? Did you also re-bend the locking tabs on those terminals that capture them in the plastic housing as well?

    If not, then thats likely the cause. Pull them back out and just give the wire terminals a slight crimp...don't crush them, and also check the locking tabs to be sure they're taking a hold firmly when you re-insert them.
  3. bltp203

    bltp203 Senior Member
    Messages: 484

    No, I just pushed the terminals in as best I could.........I will double check everything again.
  4. bltp203

    bltp203 Senior Member
    Messages: 484

    Found problem..............one of the bulb filaments streched to the point it was making contact with the other.

    Replaced the bulbs and checked wire connections. So far so good, but will have to wait for the next storm to see if it holds up.