1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Turn Signal Issues on new VXT.

Discussion in 'Boss Plows Discussion' started by White Duramax, Dec 9, 2010.

  1. White Duramax

    White Duramax Junior Member
    Messages: 13

    I just installed a 9.2 VXT on my 05 Chevy. The problem I am having is the turn signals flash on both sides of the plow when I turn either signal on in the truck. It also makes the little corner light on the truck flash on both sides. I have rechecked my pink, violet, and yellow wires and they are hooked up correctly.
     
  2. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Remove the bulbs from the plow turns. Do the left and right truck side lights still flash together? If they do not then you have a bad bulb. If they do then it's either wired incorrectly or the pink and violet is together somewhere in the harness.

    Do the marker lights work correctly?
     
  3. White Duramax

    White Duramax Junior Member
    Messages: 13

    The marker lights work correctly. I removed one bulb from the plow yesterday and turned that side turn signal on and the everything on the truck flashes correctly. I was watching both bulbs on the plow and noticed the front filament is lit for the markers and when I turn either turn signal on the front filament is what flashes. The back filament should be the one flashing. It is this way on both marker/turn bulbs in the plow.
     
  4. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Exactly what colors did you tie into on the truck?
     
  5. White Duramax

    White Duramax Junior Member
    Messages: 13

    Purple plow wire to light blue wire on drivers turn/marker plug. Yellow plow wire to brown wire on drivers turn/marker plug. Pink plow wire to passenger dark blue turn/park plug. The turn signals work correctly if the marker lights are not on.
     
  6. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    You have something going on on the plow side. Either a bad socket in one of the park/turn housings, a bad bulb (shorted filament), or the brown ground wire for the turns and parks isn't connected behind the pump cover.
     
  7. White Duramax

    White Duramax Junior Member
    Messages: 13

    Got it figured out. Thanks B&B for the tips. Found the spade connector behind the pump cover for the brown ground wire was bent and not contacting, easy fix. Also noticed a little oil residue just above the boss sticker on the pump, not sure if its a check valve or pressure regulator screwed in right there?
     
  8. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Excellent.

    The area you're describing is likely the pump pressure relieve valve cap. A slight amount seepage is ok but you can also check the cap to be sure its snug as well.