1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Truck Side wiring issue

Discussion in 'Truck & Equipment Repair' started by AC2717, Feb 22, 2010.

  1. AC2717

    AC2717 Senior Member
    Messages: 669

    Hi guys,
    Went to get inspected over the weekend and thought I needed a new dual headlight, cause the highbeam was out on the drivers side. So not a bad deal Advance had the Ultra Star's, the next model up of the Silevr Star headlights, on sale for $40 for a pair, so I picked them up put them in and same problem i think. So here is the deal

    It is a 2002 Dodge Ram 1500 with a Fisher MM2 3 plug wiring set up

    It all started about a month ago
    When I hold the control arm to flash my highbeams they flash and work fine, but when I click the control arm to leave the highbeams on the drivers side goes out and the "lamp out" light comes on.

    When I disconnected the plow wiring at the bulb and just ran the regular wiring there was no problems at all.

    When the plow is hooked up and I click the high beams on, the plow lights get really dim, but when I click the high beams off they go back to normal.

    Am I correct to say that one of the two Relays hanging off the wiring is no good?
     
  2. leon

    leon Senior Member
    Messages: 872

    lights

    If you are wearing rubber boots and holding the control arm i would suspect the grounding and the relays as a second possiblity.


    leon:waving:
     
  3. AC2717

    AC2717 Senior Member
    Messages: 669

    Sorry by control arm, I mean the blinker arm on the stearing wheel tree, the wiper/binkler control. what you use to turn on the high beams from the drivers seat.
     
  4. AC2717

    AC2717 Senior Member
    Messages: 669

    Someone has got to know this one???
     
  5. Crash935

    Crash935 2000 Club Member
    Messages: 2,377

    OH, OH, OH i know!!!





    Just not sure if i want to tell you yet!





    02 Dodge should have 4 relays, Plow high, plow low, truck high and truck low. More than likey its a bad connection at the plow high relay or a bad relay. Check the connection where the red wire comes into the relay, that has constant power to it and is prone to corrosion. If connections are good thanits probably the relay. Plow high has 2 white wires, tan wire and red wire coming into it.
     
  6. AC2717

    AC2717 Senior Member
    Messages: 669

    hmm, my plow wiring only has 2 relays built into it?
     
  7. Crash935

    Crash935 2000 Club Member
    Messages: 2,377

    hmmm exactly! Trying to figure out why you have a 3 plug harness with a straight blade also? Theres a white tag on the cross harness close to the relays, what is the # on that part of the harness?
     
  8. AC2717

    AC2717 Senior Member
    Messages: 669

    Well, ok I am sorry, I have a 4 plug isolation module and then three plugs that go to the plow unit