1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Truck Craft TC 160 spreader problems

Discussion in 'Truck & Equipment Repair' started by paul.b, Jul 15, 2016.

  1. paul.b

    paul.b Junior Member
    Messages: 2

    We run Truck Craft TC 160 salt spreaders on our dumps. Right now 3 of our 4 are having issues with the control boxes overloading on amperage and throwing a safety shut off. It seems to only happen after you dump the salt back and have the spreader tray completely full. After you run about half of the salt out the tray, the spreader functions normally. We've eliminated any kind of mechanical failure, nothing seems to be bent or bound, all electrical drive motors seem to be ok, (we've even had one of them rebuilt just in case). We can overcome the safety shut off by quickly shutting the auger off and turning it back on repeatedly before the safety triggers, but it is quite a pain. I can take the good controller and swap it into one of the trucks that fails and if functions flawlessly, which seems to confirm the lack of mechanical failure. We limped through last winter, but looking ahead to the one coming, not something we want to do again. Has anyone else had any issues with this, or any suggestions on what could be going wrong? Sending them to the manufacture for repair is possible, but rather expensive.... Any thoughts are appreciated!!