1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Troubleshooting 86110 LP 2010 model wiring

Discussion in 'Blizzard Plows Discussion' started by Probuilder72, Dec 30, 2011.

  1. Probuilder72

    Probuilder72 Junior Member
    Messages: 2

    I have a 2010 86110 LP on a '02 F350 CC dually w/ 7.3 powerstroke.
    The controller when hooking up the plow flashes slowly (power light), this is supposed to mean that there is no communication with the plow????????
    Question is, what does this mean? I have checked every plug in and fuses, all are in good shape and power is going through all plugs.
    I can't seem to find any troubleshooting info on Blizzard site for the communication or controller info.
    Any info would be greatly appreciated.
    Thank you in advance for all help.
     
  2. Sharpcut 1

    Sharpcut 1 Senior Member
    Messages: 386

    You need to shut off your controller, (hold down power button), walk to the drivers side of the plow, flip the switch closest to the moldboard foward, and then push the power button back down on your controller. It should then be solid red and controll the plow. If it does'nt work after that, you have a problem somewhere else.
     
  3. Probuilder72

    Probuilder72 Junior Member
    Messages: 2

    thank you for your help
     
  4. Sharpcut 1

    Sharpcut 1 Senior Member
    Messages: 386

    You're welcome
     
  5. Pristine PM ltd

    Pristine PM ltd PlowSite Veteran
    Messages: 3,794

    Did you put the code in?