1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Transmission, override Flashing OFF HELP PLEASE HELP

Discussion in 'Ford Trucks' started by Ovi_Ciortan, Dec 6, 2010.

  1. Ovi_Ciortan

    Ovi_Ciortan Junior Member
    Messages: 8

    HEllo to everyone,


    I have an Ford F 350 SuperDuty, Diesel 7.3, 2001. A couple of hours ago while i was plowing a commercial parking lot the override was flashing.OFF ..OFF..now it will not turn on or go away no matter what i do.

    In addition to the OD flashing OFF all the time, when im in Drive, i only get to 25-30 miles per hour. It should switch in Third Gear right? But it does not.

    This is my first year in Plowing business and i have no ideea what to do. I talked with the previous owner of the truck. He said he has no ideea of what who and why!!!!

    I need to know if you guys have an ideea of what it might be?

    Thank you for your time.
     
  2. FordFisherman

    FordFisherman PlowSite.com Addict
    from 06611
    Messages: 1,593

    How many miles on the tranny? When was it serviced last? Sounds like you could have overheated it.
     
  3. FordFisherman

    FordFisherman PlowSite.com Addict
    from 06611
    Messages: 1,593

    Possible solenoid pack also. Can you pull any codes?
     
  4. White Gardens

    White Gardens 2000 Club Member
    Messages: 2,665

    Ya, you've got something going on. Hopefully nothing severe.

    You'll need to take it somewhere and have them hook a diagnostic up to it and pull the codes.
     
  5. Too Stroked

    Too Stroked Senior Member
    Messages: 555

    On Ford trucks, the OD light flashing is basically the "You're Screwed" light. It's the truck's little way of saying it needs some attention. What's the exact problem? You'll have to pull the codes to see for sure.
     
  6. Ovi_Ciortan

    Ovi_Ciortan Junior Member
    Messages: 8

    Thanks for your reply.

    I was plowing a 3.5 acres parking lot. After almost 3 hours of plowing, i was almost done. I had one more push and i wanted to go backwards....and it would not. I thought i was stuck or something but i was not. Put it in DRIVE..nothing it would not move an inch. Turn off the engine had a smoke for 5 minutes, turned it ON and it worked. When i got to the highway ..i was doing 20-30 miles per hours...and i noticed that i wouldnt shift( i was in Drive). than the overdrive started flashing OFF. from what i know either is on or OFF. it shouldnt flash. So i pulled over to see whats wrong. I couldnt figure out what was wrong. I waited around 10 min, called all my friends in plowing bussiness...nobody had a clue!!!

    After dozens of ph calls, i decided to go home. on my way home the overdrive OFF stopped from flasing. I pushed the button and it turned off. No overdriving problem. I was really happy. I get back on the highway, put it in DRive, doing 50-60 miles pe hour, it was shifting perfectly and after 2-3 miles....AGAIN overdrive OFF..OFF....OFF flashing again. From 2 RPM it went to 3.5 rpm....instantly.

    I dont think its the tranny so far. It has to be something electrical, some fuses/modules/ Some of my friends said it might be the selenoid other say its the tranny without any doubt. I dont know what it is and i need help.

    If you guys know anything let me know,

    Thank you

    Regards,

    Ovi, Cleveland-Ohio
    (216)-255 7212.

    i will be up all night:D:p
     
  7. Ovi_Ciortan

    Ovi_Ciortan Junior Member
    Messages: 8

    i dont have any check engine on or anything like that, i went to Autozone to see if i could get some codes but nothing. NO CODES
     
  8. Ovi_Ciortan

    Ovi_Ciortan Junior Member
    Messages: 8


    It has 155k.i was serviced two days ago.But if i overheated it, than why do i get the OVERDRIVE flashing OFF?!
     
  9. Ovi_Ciortan

    Ovi_Ciortan Junior Member
    Messages: 8

    NO Codes so far
     
  10. Welderguy24

    Welderguy24 Member
    Messages: 87

    The flashing od light is the "check engine light" for the tranny and the tranny computer. The reason you could only go 30 mph or so is because the tranny went into "limp" mode to protect itself. You need to get the truck scanned by a real scanner at a shop or tranny shop, not auto zone. The codes will be in the tranny computer not the ECM
     
  11. ERWbuilders

    ERWbuilders Senior Member
    Messages: 843

    Check that wire harness it has a tendancy to rub through on the front driveshaft. check your fluid and get an aftermarket trans cooler asap the stock ones are junk. if you have the e4od like me well...its junk and once you go ahead and screw it up its time for a rebuild. baby that thing and stay out of the throtle and no passing gear. An easy diagnostics for yourself would be to do the torque converter lock mod which you can find on powerstroke.orgasm when your cruisin lock the torque converter and if it shifts firm and the rpm jump goes away your torque converter is shot. Its typical in these transmissions especially with the stock trans cooler. a transcooler is KEY on these trucks especially when plowing
     
  12. Ovi_Ciortan

    Ovi_Ciortan Junior Member
    Messages: 8

    That was nice of you to share. thank you so much. i will do that
     
  13. A&MLANDSCAPING

    A&MLANDSCAPING Junior Member
    Messages: 24

    it a neutral safety switch on the side of the tranny just put ont one one of my trucks doing the same thing
     
  14. Ovi_Ciortan

    Ovi_Ciortan Junior Member
    Messages: 8

    Now it shifts. Last night i decided to start the truck and see whats going to happen.

    It shifts normal, but after two hours of plowing the overdrive started to flash. Although its flashing OFF all the time it does shifts in third forth and so on. ..

    i am going to trany shop and see what they say. the guys from autozone they can not pull any codes. They dont have the scanner for that, only if you have the check engine on.

    I will let you know on this one. Maybe it will help others in the future!!!!
     
  15. ur probably heating up one of the pins or selonid or ur wiring harness from the shifter has a broken wire. fords have had the problem with breaking wires for a while until the finally decided to extend the harness 3''
     
  16. Jto89

    Jto89 Member
    Messages: 60

    i had the same problem with my 03 i would be plowing and the overdrive light would come on and go off and wouldn't shift past second gear. brought it to my mechanic and checked everything and couldn't seem to find a problem. i ended up having the tranny flushed and had the fluid changed and it seemed to be fine after that.
     
  17. Too Stroked

    Too Stroked Senior Member
    Messages: 555

    At a minimum, you should probably get the fluid changed / flushed. A good transmission shop is worth a bundle here and a bit of preventative maintenance can go a long way.
     
  18. ERWbuilders

    ERWbuilders Senior Member
    Messages: 843

    Just remember Ford doesnt recomend changing the filter in this trans. At all costs try not to drop the pan. Just change the fluid and get a bigger cooler.
     
  19. PAGE2004

    PAGE2004 Senior Member
    Messages: 102

    Exact same symptoms happened to me in my 97 F350 a few years ago.

    Indeed - the flashing of the overdrive light means the trans is in limp mode which is a signal to have it looked at ASAP.

    I believe, in my case it was a failed SPEED SENSOR . $125 fix at a local AAMCO transmission shop.

    I was amazed that not only was it a relatively inexpensive fix , but also that I wasnt taken to cleaners by a nationwide chain transmission shop !!

    - Good Luck and let us all know what your outcome is on this issue.
     
  20. aksobe

    aksobe Junior Member
    Messages: 10

    flashing od light

    I just had this happen to me after I installed the boss plow wiring harness. For the boss selenoid I used the ground on the front bumper. It already had a green ground wire going to it. Turns out I did not tighten the wire enough and that wire was the speed sensor/transmission ground. Check this ground wire or ANY other loose connections to the tranny. Flashing OD does mean limp mode, yes. Perhaps the wire harness is loose to the PCM?