1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Trans prob on 4L80E

Discussion in 'Chevy Trucks' started by terrapro, Feb 22, 2011.

  1. terrapro

    terrapro PlowSite Veteran
    from MI
    Messages: 3,873

    s Over the last month sometimes my trans won't shift out of 1 or 2. Now it is all the time and it will loose power after warming up the trans and take seconds to shift into first or reverse then eventually not at all. If I shut it off and let it cool down I can get a little more out of it but eventually it will do it again.

    Already replaced the speed sensor thinking that was it.
     
  2. Drottlawn

    Drottlawn Senior Member
    Messages: 364

    Sounds to me, that it is a bad torque converter, or dirty trans filter, or low on oil.:confused:
     
  3. terrapro

    terrapro PlowSite Veteran
    from MI
    Messages: 3,873

    No extra noise so I was thinking not the torque converter, fluid is fine. Changing the filter tomorrow and crossing my fingers.
     
  4. Grassman09

    Grassman09 2000 Club Member
    Messages: 2,806

    That is the same problem I had in my Dodge not long ago and the trans was already rebuilt once before. trans was torn apart again and it was a bad torque converter.

    It almost feel like you are on the brake pedal or someone is behind you with a rope not letting the truck go. Sometimes at a stop light the truck would lurk or felt like it. No un usual noise from the trans either.
     
  5. terrapro

    terrapro PlowSite Veteran
    from MI
    Messages: 3,873

    Well we ended up replacing the filter/fluid and while we were in there just to make sure we replaced both shift solenoids. Worked all morning with no problems. Dealer parts were half the cost of autoparts store just for future information.
     
  6. terrapro

    terrapro PlowSite Veteran
    from MI
    Messages: 3,873

    Nope I lied, still doing it. It is like when the trans warms up to temp it just doesn't want to shift.
     
  7. Grassman09

    Grassman09 2000 Club Member
    Messages: 2,806

    I think that is what mine did also. Prob the TC unfortunately.
     
  8. terrapro

    terrapro PlowSite Veteran
    from MI
    Messages: 3,873

    I just picked it up from the shop and they said they couldn't find anything wrong with it. A plug was full of trans fluid and they cleaned it out. So they think it is internal and I need to pull the trans for a full rebuild :confused: It is a 4L80E with a 350 in front of it, I would think this is a hard combo to kill a tranny with especially if the fluid was fine and there were no bands or metal shavings in the pan.
     
  9. Mr.Markus

    Mr.Markus PlowSite Fanatic
    Messages: 5,163

    The 4L80E/ 4L60 are by far not bullet proof. Try some "Seafoam Trans Tune" in the fresh oil, it'll help loosen up any gunk in there. It's a good product that I even add to my plow oil for lubricating seals and preventing freeze up. Cheap too at $9 a bottle.