1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

tranny

Discussion in 'Chevy Trucks' started by 572bowtie, Dec 15, 2004.

  1. 572bowtie

    572bowtie Member
    Messages: 44

    i have a 79 k-10 and just today it would not go into drive only reverse and neutral is my tranny shot?
     
  2. 78K20

    78K20 Member
    from WV
    Messages: 49

    Make sure its running and in park and check the fluid level. Smell it, if it smells burned you most likely will need a rebuild. I assume you have a th350 tranny, if so the modulator is on the back of the tranny. See if the vacuum line is connected check the line all the way to the engine. Even if the line is disconnected it should still move foward but its worth a try. Also you could take the pan down and check to see if the filter is clogged, look for metal shavings in the bottom of the pan. There is a similar post in the ford truck disscusion about tranny failure. That lucas tranny stuff is pretty good ,helped my dads truck from slipping, you might add it if you tranny turns out to be ok. hope this helps
     
  3. Tarkus

    Tarkus PlowSite.com Addict
    Messages: 1,113


    Sounds like the forward clutch is shot or not engaging because of valve body or clutch drive seal issue. This will likey need a tear down.